Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Plugin · leyka

Leyka

14 known vulnerabilities on record. Add your version above to see which ones affect you.

Is Leyka safe? The full page →

  • Oct 10, 2026Administrator SQL Injection in Leyka <= 3.32.3 versions.CVE-2026-42717 · affects up to 3.32.3 · reported by PatchstackHigh 7.6

    Administrator SQL Injection in Leyka <= 3.32.3 versions.

  • Aug 20, 2026Subscriber Broken Authentication in Leyka <= 3.32.3 versions.CVE-2026-66677 · affects up to 3.32.3 · reported by PatchstackHigh 7.6

    Subscriber Broken Authentication in Leyka <= 3.32.3 versions.

  • Jul 4, 2025Leyka: Path Traversal: '.../...//'CVE-2025-52805 · affects up to 3.32.1 · reported by PatchstackHigh 7.5

    Path Traversal: '.../...//' vulnerability in VaultDweller Leyka leyka allows PHP Local File Inclusion.This issue affects Leyka: from n/a through <= 3.32.1.

  • Jun 27, 2025Leyka: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-53275 · affects up to 3.32.1 · reported by PatchstackMedium 6.5

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VaultDweller Leyka leyka allows DOM-Based XSS.This issue affects Leyka: from n/a through <= 3.32.1.

  • Feb 16, 2025Leyka: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-26766 · affects up to 3.31.8 · reported by PatchstackMedium 6.5

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VaultDweller Leyka leyka allows Stored XSS.This issue affects Leyka: from n/a through <= 3.31.8.

  • Oct 16, 2024Leyka: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2024-49252 · affects up to 3.31.6 · reported by PatchstackMedium 5.3

    Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in VaultDweller Leyka leyka.This issue affects Leyka: from n/a through <= 3.31.6.

  • Jun 11, 2024Leyka: Missing AuthorizationCVE-2024-35683 · affects up to 3.31.1 · reported by PatchstackMedium 5.3

    Missing Authorization vulnerability in Teplitsa of social technologies Leyka.This issue affects Leyka: from n/a through 3.31.1.

  • May 14, 2024Leyka: Improper Privilege ManagementCVE-2023-33327 · affects up to 3.30.2 · reported by PatchstackHigh 8.8

    Improper Privilege Management vulnerability in Teplitsa of social technologies Leyka allows Privilege Escalation.This issue affects Leyka: from n/a through 3.30.2.

  • Nov 22, 2023Cross-Site Request Forgery (CSRF) vulnerability in Teplitsa of social technologies Leyka plugin <= 3.29.2 versions.CVE-2023-27442 · affects up to 3.29.2 · reported by PatchstackMedium 5.4

    Cross-Site Request Forgery (CSRF) vulnerability in Teplitsa of social technologies Leyka plugin <= 3.29.2 versions.

  • Sep 19, 2023Leyka: Does not sanitise and escape some of its settingsCVE-2023-2995 · fixed in 3.30.4 · reported by WPScanMedium 4.8

    The Leyka WordPress plugin before 3.30.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

  • Sep 12, 2023Leyka: Sensitive Information ExposureCVE-2023-4917 · affects up to 3.30.7 · reported by WordfenceMedium 5.3

    The Leyka plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 3.30.7 via the 'leyka_ajax_get_env_and_options' function. This can allow authenticated attackers with subscriber-level permissions or above to extract sensitive data including Sberbank API key and password, PayPal Client Secret, and more keys and passwords.

  • Aug 30, 2023Unauth.CVE-2023-33325 · affects up to 3.30.1 · reported by PatchstackHigh 7.1

    Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Teplitsa of social technologies Leyka plugin <= 3.30.1 versions.

  • Aug 10, 2023Unauth.CVE-2023-39314 · affects up to 3.30.2 · reported by PatchstackHigh 7.1

    Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Teplitsa of social technologies Leyka plugin <= 3.30.2 versions.

  • Jun 21, 2023Unauth.CVE-2023-27450 · affects up to 3.29.2 · reported by PatchstackHigh 7.1

    Unauth. Stored Cross-Site Scripting (XSS) vulnerability in Teplitsa of social technologies Leyka plugin <= 3.29.2 versions.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.