WordPress plugin · leyka
Is Leyka safe?
Closed. Replace it.
wordpress.org closed it on Sep 11, 2026, so it gets no more security fixes, and 14 flaws are on record. If your site runs it, move to a maintained alternative.
- Flaws on record
- 14
- High or critical
- 7
- Exploited
- none
Every recorded flaw
- Oct 10, 2026Administrator SQL Injection in Leyka <= 3.32.3 versions.CVE-2026-42717 · affects up to 3.32.3 · reported by PatchstackHigh 7.6
- Aug 20, 2026Subscriber Broken Authentication in Leyka <= 3.32.3 versions.CVE-2026-66677 · affects up to 3.32.3 · reported by PatchstackHigh 7.6
- Jul 4, 2025Leyka: Path Traversal: '.../...//'CVE-2025-52805 · affects up to 3.32.1 · reported by PatchstackHigh 7.5
- Jun 27, 2025Leyka: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-53275 · affects up to 3.32.1 · reported by PatchstackMedium 6.5
- Feb 16, 2025Leyka: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-26766 · affects up to 3.31.8 · reported by PatchstackMedium 6.5
- Oct 16, 2024Leyka: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2024-49252 · affects up to 3.31.6 · reported by PatchstackMedium 5.3
- Jun 11, 2024Leyka: Missing AuthorizationCVE-2024-35683 · affects up to 3.31.1 · reported by PatchstackMedium 5.3
- May 14, 2024Leyka: Improper Privilege ManagementCVE-2023-33327 · affects up to 3.30.2 · reported by PatchstackHigh 8.8
- Nov 22, 2023Cross-Site Request Forgery (CSRF) vulnerability in Teplitsa of social technologies Leyka plugin <= 3.29.2 versions.CVE-2023-27442 · affects up to 3.29.2 · reported by PatchstackMedium 5.4
- Sep 19, 2023Leyka: Does not sanitise and escape some of its settingsCVE-2023-2995 · fixed in 3.30.4 · reported by WPScanMedium 4.8
- Sep 12, 2023Leyka: Sensitive Information ExposureCVE-2023-4917 · affects up to 3.30.7 · reported by WordfenceMedium 5.3
- Aug 30, 2023Unauth.CVE-2023-33325 · affects up to 3.30.1 · reported by PatchstackHigh 7.1
- Aug 10, 2023Unauth.CVE-2023-39314 · affects up to 3.30.2 · reported by PatchstackHigh 7.1
- Jun 21, 2023Unauth.CVE-2023-27450 · affects up to 3.29.2 · reported by PatchstackHigh 7.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.