Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Plugin · i-recommend-this

i-recommend-this

4 known vulnerabilities on record. Add your version above to see which ones affect you.

Is i-recommend-this safe? The full page →

  • Nov 12, 2023I Recommend This: Cross-Site Request Forgery (CSRF)CVE-2023-28696 · affects up to 3.9.0 · reported by PatchstackMedium 4.3

    Cross-Site Request Forgery (CSRF) vulnerability in Harish Chouhan, Themeist I Recommend This allows Cross Site Request Forgery.This issue affects I Recommend This: from n/a through 3.9.0.

  • May 16, 2023Auth.CVE-2023-23673 · affects up to 3.8.3 · reported by PatchstackMedium 5.9

    Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Harish Chouhan, Themeist I Recommend This plugin <= 3.8.3 versions.

  • Apr 20, 2023A vulnerability has been found in I Recommend This Plugin up to 3.7.2 on WordPress and classified as critical.CVE-2014-125099 · affects up to 3.7.2 · reported by VulDBMedium 6.3

    A vulnerability has been found in I Recommend This Plugin up to 3.7.2 on WordPress and classified as critical. Affected by this vulnerability is an unknown functionality of the file dot-irecommendthis.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 3.7.3 is able to address this issue. The identifier of the patch is 058b3ef5c7577bf557557904a53ecc8599b13649. It is recommended to upgrade the affected component. The identifier VDB-226309 was assigned to this vulnerability.

  • Aug 16, 2019The i-recommend-this plugin before 3.7.3 for WordPress has SQL injection.CVE-2014-10376 · fixed in 3.7.3 · reported by MITRECritical 9.8

    The i-recommend-this plugin before 3.7.3 for WordPress has SQL injection.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.