WordPress plugin · i-recommend-this
Is I Recommend This safe?
Safe on 4.0.1 or newer.
The current version, 4.0.1, is past every affected range on record (4 of 4 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 4
- High or critical
- 1
- Exploited
- none
- Current version
- 4.0.1
- Last updated
- Jul 25, 2025
- Active installs
- 4,000+
Every recorded flaw
- Nov 12, 2023I Recommend This: Cross-Site Request Forgery (CSRF)CVE-2023-28696 · affects up to 3.9.0 · reported by PatchstackMedium 4.3
- May 16, 2023Auth.CVE-2023-23673 · affects up to 3.8.3 · reported by PatchstackMedium 5.9
- Apr 20, 2023A vulnerability has been found in I Recommend This Plugin up to 3.7.2 on WordPress and classified as critical.CVE-2014-125099 · affects up to 3.7.2 · reported by VulDBMedium 6.3
- Aug 16, 2019The i-recommend-this plugin before 3.7.3 for WordPress has SQL injection.CVE-2014-10376 · fixed in 3.7.3 · reported by MITRE1.8% oddsCritical 9.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.