WordPress plugin · xcloner-backup-and-restore
Is Backup, Restore and Migrate your sites with XCloner safe?
Safe on 4.8.8 or newer.
The current version, 4.8.8, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 0
- Exploited
- none
- Current version
- 4.8.8
- Last updated
- Oct 28, 2026
- Active installs
- 10,000+
Every recorded flaw
- Jun 15, 2026Subscriber Sensitive Data Exposure in XCloner <= 4.8.6 versions.CVE-2026-48965 · affects up to 4.8.6 · reported by PatchstackMedium 6.5
- Dec 4, 2025Backup, Restore and Migrate your sites with XCloner: Cross-Site Request ForgeryCVE-2025-11759 · affects up to 4.8.2 · reported by WordfenceMedium 4.3
- Jul 16, 2024Backup, Restore and Migrate WordPress Sites With the XCloner: Full Path DisclosureCVE-2024-6559 · affects up to 4.7.3 · reported by WordfenceMedium 5.3
- Jun 27, 2022Backup, Restore and Migrate WordPress Sites With the XCloner: Does not have authorisation and CSRF checksCVE-2022-0444 · fixed in 4.3.6 · reported by WPScanMedium 4.3
- Jun 17, 2015Static code injection vulnerability in the XCloner plugin 3.1.2 for WordPress allows remote authenticated users to inject arbitrary PHP code into the language fCVE-2015-4338 · affects 3.1.2 to 3.1.2 · reported by MITRE2.3% oddsMedium 6.5
- Jun 17, 2015Cross-site scripting (XSS) vulnerability in the XCloner plugin 3.1.2 for WordPress allows remote authenticated users to inject arbitrary web script or HTML via CVE-2015-4337 · affects 3.1.2 to 3.1.2 · reported by MITRE1.6% oddsLow 3.5
- Jun 17, 2015cloner.functions.php in the XCloner plugin 3.1.2 for WordPress allows remote authenticated users to execute arbitrary commands via a file containing filenames wCVE-2015-4336 · affects 3.1.2 to 3.1.2 · reported by MITRE2.6% oddsMedium 6.5
- Jun 10, 2015Directory traversal vulnerability in the XCloner plugin 3.1.1 for WordPress and 3.5.1 for Joomla! allows remote administrators to read arbitrary files via a ..CVE-2014-8606 · affects 3.1.1 to 3.1.1 · reported by MITRE6.0% oddsMedium 4
- Jun 10, 2015cloner.functions.php in the XCloner plugin 3.1.1 for WordPress and 3.5.1 for Joomla! allows remote administrators to execute arbitrary code via shell metacharacCVE-2014-8603 · affects 3.1.1 to 3.1.1 · reported by MITRE6.2% oddsMedium 6.5
- Apr 3, 2014Cross-site request forgery (CSRF) vulnerability in the XCloner plugin before 3.1.1 for WordPress allows remote attackers to hijack the authentication of adminisCVE-2014-2340 · fixed in 3.1.1 · reported by MITRE2.8% oddsMedium 6.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.