WordPress plugin · wsecure
Is wsecure lite safe?
Safe on 3.3 or newer.
The current version, 3.3, is past every affected range on record (2 of 2 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 2
- High or critical
- 1
- Exploited
- none
- Current version
- 3.3
- Last updated
- Sep 16, 2026
- Active installs
- 200+
Every recorded flaw
- Sep 4, 2023Auth.CVE-2023-39987 · affects up to 2.5 · reported by PatchstackMedium 5.9
- Sep 16, 2019The wsecure plugin before 2.4 for WordPress has remote code execution via shell metacharacters in the wsecure-config.php publish parameter.CVE-2016-10960 · fixed in 2.4 · reported by MITRE9.0% oddsHigh 8.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.