WordPress plugin · wpml
Is wpml safe?
Closed. Replace it.
wordpress.org closed it on Sep 2, 2011 (unknown), so it gets no more security fixes, and 3 flaws are on record. If your site runs it, move to a maintained alternative.
- Flaws on record
- 3
- High or critical
- 2
- Exploited
- none
Every recorded flaw
- May 2, 2025WPML: Stored Cross-Site ScriptingCVE-2025-3488 · affects 3.6.0 to 4.7.3 · reported by WordfenceMedium 6.4
- Aug 21, 2024WPML: Remote Code ExecutionCVE-2024-6386 · affects up to 4.6.12 · reported by Wordfence26% oddsCritical 9.9
- Mar 30, 2015The WPML plugin before 3.1.9 for WordPress does not properly handle multiple actions in a request, which allows remote attackers to bypass nonce checks and perfCVE-2015-2792 · fixed in 3.1.9 · reported by MITRE3.8% oddsHigh 7.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.