WordPress plugin · wpdiscuz
Is Comments safe?
Safe on 7.6.73 or newer.
The current version, 7.6.73, is past every affected range on record (35 of 35 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 35
- High or critical
- 6
- Exploited
- none
- Current version
- 7.6.73
- Last updated
- Oct 25, 2026
- Active installs
- 60,000+
Every recorded flaw
- Sep 2, 2026Comments: Does not validate a value used to build a database queryCVE-2026-19704 · fixed in 7.6.66 · reported by WPScanMedium 5.3
- Aug 7, 2026Comments: Does not properly escape a user-supplied URL before outputting it inside an HTML attributeCVE-2026-15032 · fixed in 7.6.60 · reported by WPScanMedium 6.1
- Jul 3, 2026Comments – wpDiscuz: Stored Cross-Site ScriptingCVE-2026-9148 · affects up to 7.6.56 · reported by WordfenceHigh 7.2
- Mar 13, 2026wpDiscuz before 7.6.47 contains a missing rate limiting vulnerability that allows unauthenticated attackers to subscribe arbitrary email addresses to post notifCVE-2026-22216 · fixed in 7.6.47 · reported by VulnCheckMedium 6.9
- Mar 13, 2026the getFollowsPage() function that: WpDiscuz before 7.6.47 contains a cross-site request forgeryCVE-2026-22215 · fixed in 7.6.47 · reported by VulnCheckMedium 5.3
- Mar 13, 2026wpDiscuz before 7.6.47 contains a cross-site scripting vulnerability that allows attackers to inject malicious code through unescaped attachment URLs in HTML ouCVE-2026-22210 · fixed in 7.6.47 · reported by VulnCheckLow 2.1
- Mar 13, 2026the customCss field that: WpDiscuz before 7.6.47 contains a cross-site scriptingCVE-2026-22209 · fixed in 7.6.47 · reported by VulnCheckMedium 5.1
- Mar 13, 2026wpDiscuz before 7.6.47 contains an email header injection vulnerability that allows attackers to manipulate mail recipients by injecting malicious data into theCVE-2026-22204 · fixed in 7.6.47 · reported by VulnCheckMedium 6.3
- Mar 13, 2026wpDiscuz before 7.6.47 contains an information disclosure vulnerability that allows administrators to inadvertently expose OAuth secrets by exporting plugin optCVE-2026-22203 · fixed in 7.6.47 · reported by VulnCheckMedium 6.9
- Mar 13, 2026wpDiscuz before 7.6.47 contains a cross-site request forgery vulnerability that allows attackers to delete all comments associated with an email address by crafCVE-2026-22202 · fixed in 7.6.47 · reported by VulnCheckMedium 6.1
- Mar 13, 2026the getIP() function that: WpDiscuz before 7.6.47 contains an IP spoofingCVE-2026-22201 · fixed in 7.6.47 · reported by VulnCheckMedium 6.9
- Mar 13, 2026the getAllSubscriptions() function where string parameters lack proper quote escaping in SQL queries: WpDiscuz before 7.6.47 contains an SQL injectionCVE-2026-22193 · fixed in 7.6.47 · reported by VulnCheckCritical 9.2
- Mar 13, 2026the inline comment preview functionality that: WpDiscuz before 7.6.47 contains a stored cross-site scriptingCVE-2026-22183 · fixed in 7.6.47 · reported by VulnCheckMedium 5.3
- Mar 13, 2026wpDiscuz before 7.6.47 contains an unauthenticated denial of service vulnerability that allows anonymous users to trigger mass notification emails by exploitingCVE-2026-22182 · fixed in 7.6.47 · reported by VulnCheckHigh 8.7
- Jan 1, 2026Comments: Does not properly validate user's identityCVE-2025-13820 · fixed in 7.6.40 · reported by WPScanMedium 5.3
- Dec 30, 2025wpDiscuz: Authorization Bypass Through User-Controlled KeyCVE-2025-68997 · affects up to 7.6.43 · reported by PatchstackMedium 5.3
- Sep 22, 2025wpDiscuz: Missing AuthorizationCVE-2025-59591 · affects up to 7.6.33 · reported by PatchstackMedium 4.3
- Jan 2, 2025wpDiscuz: Missing AuthorizationCVE-2023-46309 · affects up to 7.6.10 · reported by PatchstackMedium 5.3
- Jan 2, 2025wpDiscuz: Missing AuthorizationCVE-2023-45760 · affects up to 7.6.3 · reported by PatchstackMedium 4.3
- Oct 25, 2024Comments – wpDiscuz: Authentication bypassCVE-2024-9488 · affects up to 7.6.24 · reported by WordfenceCritical 9.8
- Aug 2, 2024Comments – wpDiscuz: HTML InjectionCVE-2024-6704 · affects up to 7.6.21 · reported by WordfenceMedium 5.3
- Jun 8, 2024wpDiscuz: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-35681 · affects up to 7.6.18 · reported by PatchstackMedium 6.5
- Jun 4, 2024wpDiscuz: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)CVE-2023-46310 · affects up to 7.6.10 · reported by PatchstackMedium 5.3
- Apr 23, 2024wpDiscuz: Stored Cross-Site ScriptingCVE-2024-2477 · affects up to 7.6.15 · reported by WordfenceMedium 6.4
- Feb 1, 2024Comments – wpDiscuz: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-51691 · affects up to 7.6.12 · reported by PatchstackMedium 5.9
- Dec 20, 2023Comments – wpDiscuz: Authorization Bypass Through User-Controlled KeyCVE-2023-46311 · affects up to 7.6.3 · reported by PatchstackLow 2.7
- Nov 22, 2023Cross-Site Request Forgery (CSRF) vulnerability in gVectors Team Comments — wpDiscuz plugin <= 7.6.11 versions.CVE-2023-47775 · fixed in 7.6.12 · reported by PatchstackMedium 4.3
- Nov 6, 2023Unauth.CVE-2023-47185 · affects up to 7.6.11 · reported by PatchstackHigh 7.1
- Oct 20, 2023wpDiscuz: Unauthorized modification of dataCVE-2023-3998 · affects up to 7.6.3 · reported by WordfenceMedium 5.3
- Oct 20, 2023wpDiscuz: Unauthorized modification of dataCVE-2023-3869 · affects up to 7.6.3 · reported by WordfenceMedium 5.3
- Nov 18, 2022Auth.CVE-2022-43492 · affects 7.4.2 to 7.4.2 · reported by PatchstackMedium 4.3
- Feb 21, 2022Sensitive information disclosure discovered in wpDiscuz WordPress plugin (versions <= 7.3.11).CVE-2022-23984 · affects up to 7.3.11 · reported by Patchstack1.1% oddsLow 3.7
- Nov 8, 2021wpDiscuz: Does check for CSRFCVE-2021-24806 · fixed in 7.3.4 · reported by WPScanMedium 4.3
- Oct 11, 2021Comments – wpDiscuz: Does not properly sanitise or escape the Follow and Unfollow messages before outputting them in the pageCVE-2021-24737 · affects up to 7.3.0 · reported by WPScanMedium 4.8
- Jun 18, 2020A SQL injection issue in the gVectors wpDiscuz plugin 5.3.5 and earlier for WordPress allows remote attackers to execute arbitrary SQL commands via the order paCVE-2020-13640 · affects up to 5.3.5 · reported by MITRE13% oddsCritical 9.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.