WordPress plugin · wp-ulike
Is WP ULike safe?
Safe on 5.2.5 or newer.
The current version, 5.2.5, is past every affected range on record (15 of 15 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 15
- High or critical
- 1
- Exploited
- none
- Current version
- 5.2.5
- Last updated
- Oct 17, 2026
- Active installs
- 60,000+
Every recorded flaw
- Mar 11, 2026WP ULike: Stored Cross-Site ScriptingCVE-2026-2358 · affects up to 5.0.1 · reported by WordfenceMedium 6.4
- Feb 2, 2026WP ULike: Insecure Direct Object ReferenceCVE-2026-0909 · affects up to 4.8.3.1 · reported by WordfenceMedium 5.3
- May 15, 2025WP ULike: Does not sanitise and escape some of its settingsCVE-2024-12770 · fixed in 4.7.6 · reported by WPScanMedium 4.8
- Apr 10, 2025WP ULike: Missing AuthorizationCVE-2025-32259 · affects up to 4.7.9.1 · reported by PatchstackMedium 5.3
- Jan 15, 2025WP ULike: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-22738 · affects up to 4.7.6 · reported by PatchstackMedium 5.9
- Nov 6, 2024WP ULike: Does not sanitise and escape some of its settingsCVE-2024-7879 · fixed in 4.7.5 · reported by WPScanMedium 4.8
- Oct 15, 2024WP ULike – The Ultimate Engagement Toolkit for Websites: Cross-Site Request ForgeryCVE-2024-9649 · affects up to 4.7.4 · reported by WordfenceMedium 4.3
- Sep 25, 2024WP ULike: Does not sanitise and escape some of its settingsCVE-2024-7878 · fixed in 4.7.4 · reported by WPScanMedium 4.8
- Sep 6, 2024WP ULike: Does not properly sanitize user display namesCVE-2024-6792 · fixed in 4.7.2.1 · reported by WPScanLow 3.5
- Jul 24, 2024WP ULike: Does not sanitise and escape some of its settingsCVE-2024-6094 · fixed in 4.7.1 · reported by WPScanMedium 4.8
- May 2, 2024WP ULike – Most Advanced WordPress Marketing Toolkit: SQL InjectionCVE-2024-1797 · affects up to 4.6.9 · reported by WordfenceHigh 8.8
- May 2, 2024WP ULike – Most Advanced WordPress Marketing Toolkit: Stored Cross-Site ScriptingCVE-2024-1759 · affects up to 4.6.9 · reported by WordfenceMedium 6.4
- May 2, 2024WP ULike: Stored Cross-Site ScriptingCVE-2024-1572 · affects up to 4.6.9 · reported by WordfenceMedium 6.4
- Oct 25, 2023Auth.CVE-2023-45640 · affects up to 4.6.8 · reported by PatchstackMedium 6.5
- Nov 30, 2022Unauth.CVE-2022-45842 · affects up to 4.6.4 · reported by PatchstackMedium 5.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.