WordPress plugin · wp-table-builder
Is WP Table Builder safe?
Safe on 2.2.4 or newer.
The current version, 2.2.4, is past every affected range on record (11 of 11 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 11
- High or critical
- 2
- Exploited
- none
- Current version
- 2.2.4
- Last updated
- Oct 12, 2026
- Active installs
- 50,000+
Every recorded flaw
- Sep 22, 2026WP Table Builder – Drag & Drop Table Builder: Incorrect AuthorizationCVE-2026-6922 · affects up to 2.2.1 · reported by WordfenceHigh 7.1
- Aug 18, 2026Contributor Broken Access Control in WP Table Builder <= 2.2.0 versions.CVE-2026-74006 · affects up to 2.2.0 · reported by PatchstackMedium 4.3
- Jan 9, 2026WP Table Builder – Drag & Drop Table Builder: Unauthorized modification of dataCVE-2025-13753 · affects up to 2.0.19 · reported by WordfenceMedium 4.3
- Aug 15, 2025WP Table Builder – WordPress Table: Stored Cross-Site ScriptingCVE-2025-8604 · affects up to 2.0.12 · reported by WordfenceMedium 6.4
- Aug 14, 2025WP Table Builder: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-55711 · affects up to 2.0.12 · reported by PatchstackMedium 6.5
- Jun 6, 2025WP Table Builder: Cross-Site Request Forgery (CSRF)CVE-2025-49286 · affects up to 2.0.6 · reported by PatchstackMedium 4.3
- Apr 11, 2025WP Table Builder: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-32598 · affects up to 2.0.5 · reported by PatchstackHigh 7.1
- Aug 23, 2024WP Table Builder: Does not sanitise and escape some of its Table dataCVE-2024-3282 · affects up to 1.5.0 · reported by WPScanMedium 4.8
- Aug 12, 2024WP Table Builder – WordPress Table: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-43125 · affects up to 1.4.15 · reported by PatchstackMedium 6.5
- May 21, 2024WP Table Builder – WordPress Table: Stored Cross-Site ScriptingCVE-2024-4700 · affects up to 1.4.14 · reported by WordfenceMedium 6.4
- May 3, 2023Auth.CVE-2022-46852 · fixed in 1.4.7 · reported by PatchstackMedium 5.9
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.