WordPress plugin · wp-members
Is WP-Members Membership Plugin safe?
Safe on 3.5.8.3 or newer.
The current version, 3.5.8.3, is past every affected range on record (19 of 19 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 19
- High or critical
- 2
- Exploited
- none
- Current version
- 3.5.8.3
- Last updated
- Oct 27, 2026
- Active installs
- 50,000+
Every recorded flaw
- Oct 12, 2026WP-Members: Missing AuthorizationCVE-2026-61994 · affects up to 3.5.7 · reported by PatchstackMedium 5.4
- Sep 11, 2026WP-Members Membership: Reflected Cross-Site ScriptingCVE-2026-84960 · affects up to 3.5.6 · reported by WordfenceMedium 6.1
- Mar 4, 2026WP-Members Membership: SQL InjectionCVE-2026-2363 · affects up to 3.5.5.1 · reported by WordfenceMedium 6.5
- Jan 15, 2026WP-Members Membership: Stored Cross-Site ScriptingCVE-2025-14448 · affects up to 3.5.4.3 · reported by WordfenceMedium 5.4
- Jan 7, 2026WP-Members Membership: Unauthorized file accessCVE-2025-12648 · affects up to 3.5.4.4 · reported by WordfenceMedium 5.3
- Sep 22, 2025WP-Members: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-57973 · affects up to 3.5.4.2 · reported by PatchstackMedium 5.5
- Sep 9, 2025The WP-Members Membership: Arbitrary shortcode executionCVE-2025-9489 · affects up to 3.5.4.2 · reported by WordfenceMedium 5
- Jul 22, 2025WP-Members Membership: Stored Cross-Site ScriptingCVE-2025-7495 · affects up to 3.5.4.1 · reported by WordfenceMedium 6.4
- Jun 20, 2025WP-Members: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-50051 · affects up to 3.5.4 · reported by PatchstackMedium 6.5
- May 17, 2025WP-Members Membership: Stored Cross-Site ScriptingCVE-2025-4610 · affects up to 3.5.2 · reported by WordfenceMedium 6.4
- Oct 25, 2024WP-Members Membership: Stored Cross-Site ScriptingCVE-2024-10374 · affects up to 3.4.9.5 · reported by WordfenceMedium 6.4
- Oct 22, 2024WP-Members Membership: Reflected Cross-Site ScriptingCVE-2024-9231 · affects up to 3.4.9.5 · reported by WordfenceMedium 6.1
- Apr 26, 2024WP-Members Membership: Information ExposureCVE-2024-2920 · affects up to 3.4.9.3 · reported by WordfenceMedium 5.3
- Apr 9, 2024WP-Members Membership: Stored Cross-Site ScriptingCVE-2024-1852 · affects up to 3.4.9.2 · reported by WordfenceHigh 7.2
- Mar 8, 2024WP-Members Membership: Stored Cross-Site ScriptingCVE-2024-1987 · affects up to 3.4.9.1 · reported by WordfenceMedium 6.4
- Jan 3, 2024WP-Members Membership: Sensitive Information ExposureCVE-2023-6733 · affects up to 3.4.8 · reported by WordfenceMedium 6.5
- Jul 12, 2023WP-Members Membership: Unauthorized plugin settings updateCVE-2023-2869 · affects up to 3.4.7.3 · reported by WordfenceMedium 4.3
- Aug 27, 2019The wp-members plugin before 3.2.8 for WordPress has CSRF.CVE-2019-15660 · fixed in 3.2.8 · reported by MITREHigh 8.8
- Jul 7, 2017WP-Members prior to version 3.1.8: Cross-site scriptingCVE-2017-2222 · affects up to 3.1.7 · reported by vultures@jpcert.or.jp1.8% oddsMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.