WordPress plugin · wp-mailster
Is WP Mailster safe?
Safe on 1.9.2.0 or newer.
The current version, 1.9.2.0, is past every affected range on record (18 of 18 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 18
- High or critical
- 9
- Exploited
- none
- Current version
- 1.9.2.0
- Last updated
- Oct 18, 2026
- Active installs
- 300+
Every recorded flaw
- Oct 22, 2026WP Mailster: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2026-111830 · affects up to 1.9.1.0 · reported by PatchstackHigh 7.1
- Oct 21, 2026WP Mailster: Unrestricted Upload of File with Dangerous TypeCVE-2026-111832 · affects up to 1.9.1.0 · reported by PatchstackCritical 10
- Oct 19, 2026WP Mailster: Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')CVE-2026-111829 · affects up to 1.9.1.0 · reported by PatchstackMedium 6.5
- Oct 6, 2026Unauthenticated Cross Site Scripting (XSS) in WP Mailster <= 1.9.0.0 versions.CVE-2026-105061 · affects up to 1.9.0.0 · reported by PatchstackHigh 7.1
- Oct 5, 2026WP Mailster: Missing AuthorizationCVE-2026-105055 · affects up to 1.9.0.0 · reported by PatchstackMedium 5.3
- Feb 14, 2025WP Mailster: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-24688 · affects up to 1.8.20.0 · reported by PatchstackHigh 7.1
- Feb 14, 2025WP Mailster: Insertion of Sensitive Information Into Sent DataCVE-2025-24567 · affects up to 1.8.16.0 · reported by PatchstackMedium 6.5
- Feb 4, 2025WP Mailster: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-24598 · affects up to 1.8.17.0 · reported by PatchstackHigh 7.1
- Feb 3, 2025WP Mailster: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-24559 · affects up to 1.8.15.0 · reported by PatchstackHigh 7.1
- Jan 7, 2025WP Mailster: Insertion of Sensitive Information Into Sent DataCVE-2025-22303 · affects up to 1.8.17.0 · reported by PatchstackMedium 5.3
- Dec 16, 2024WP Mailster: Cross-Site Request Forgery (CSRF)CVE-2024-54355 · affects up to 1.8.17.0 · reported by PatchstackMedium 4.3
- Dec 6, 2024WP Mailster: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2024-53807 · affects up to 1.8.16.0 · reported by PatchstackHigh 8.5
- Dec 6, 2024WP Mailster: Missing AuthorizationCVE-2024-53805 · affects up to 1.8.16.0 · reported by PatchstackHigh 7.5
- Dec 6, 2024WP Mailster: Insertion of Sensitive Information Into Sent DataCVE-2024-53804 · affects up to 1.8.16.0 · reported by PatchstackHigh 7.5
- Dec 6, 2024WP Mailster: Missing AuthorizationCVE-2024-53803 · affects up to 1.8.16.0 · reported by PatchstackMedium 6.5
- Dec 3, 2024WP Mailster: Stored Cross-Site ScriptingCVE-2024-11782 · affects up to 1.8.17.0 · reported by WordfenceMedium 6.4
- Nov 28, 2024WP Mailster: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-53737 · affects up to 1.8.16.0 · reported by PatchstackMedium 6.5
- Dec 6, 2017The WP Mailster plugin before 1.5.5 for WordPress has XSS in the unsubscribe handler via the mes parameter to view/subscription/unsubscribe2.php.CVE-2017-17451 · fixed in 1.5.5 · reported by MITRE5.1% oddsMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.