WordPress plugin · wp-google-map-plugin
Is WP Maps safe?
Safe on 5.0.3 or newer.
The current version, 5.0.3, is past every affected range on record (28 of 28 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 28
- High or critical
- 12
- Exploited
- none
- Current version
- 5.0.3
- Last updated
- Oct 28, 2026
- Active installs
- 60,000+
Every recorded flaw
- Sep 25, 2026WP Maps – Google Maps,OpenStreetMap,Mapbox,Store Locator,Listing,Directory & Filters: Local File InclusionCVE-2026-13456 · affects up to 4.9.8 · reported by WordfenceHigh 7.5
- Sep 25, 2026WP Maps – Google Maps,OpenStreetMap,Mapbox,Store Locator,Listing,Directory & Filters: Stored Cross-Site ScriptingCVE-2026-13179 · affects up to 4.9.8 · reported by WordfenceMedium 6.4
- Sep 17, 2026Administrator SQL Injection in WP Maps <= 4.9.9 versions.CVE-2026-66618 · affects up to 4.9.9 · reported by PatchstackHigh 7.6
- Aug 19, 2026WP Maps: Does not perform a capability checkCVE-2026-18466 · fixed in 4.9.8 · reported by WPScanMedium 5.4
- Aug 7, 2026WP Maps: Does not perform a capability check in one of its AJAX actions and does not restrict the operation it dispatchesCVE-2026-16265 · fixed in 4.9.7 · reported by WPScanMedium 6.5
- Aug 7, 2026WP Maps: Does not perform a capability check in one of its AJAX actions and does not properly validate a user-controlled path before using it in a file inclusionCVE-2026-16263 · fixed in 4.9.7 · reported by WPScanHigh 8.8
- Jul 31, 2026WP Maps: Insertion of Sensitive Information Into Sent DataCVE-2026-28144 · affects up to 4.9.6 · reported by PatchstackMedium 4.3
- Jun 15, 2026Unauthenticated SQL Injection in WP Maps <= 4.9.1 versions.CVE-2026-39492 · affects up to 4.9.1 · reported by PatchstackCritical 9.3
- Jun 6, 2026WP Maps – Google Maps,OpenStreetMap,Mapbox,Store Locator,Listing,Directory & Filters: Stored Cross-Site ScriptingCVE-2026-9594 · affects up to 4.9.4 · reported by WordfenceMedium 4.4
- May 18, 2026WP Maps: Does not properly sanitize a parameter before using it in a file pathCVE-2026-6381 · fixed in 4.9.3 · reported by WPScanHigh 7.5
- Apr 16, 2026WP Maps – Store Locator,Google Maps,OpenStreetMap,Mapbox,Listing,Directory & Filters: Stored Cross-Site ScriptingCVE-2025-13364 · affects up to 4.8.7 · reported by WordfenceMedium 6.4
- Mar 22, 2026WP Maps – Store Locator,Google Maps,OpenStreetMap,Mapbox,Listing,Directory & Filters: Time-based SQL InjectionCVE-2026-2580 · affects up to 4.9.1 · reported by WordfenceHigh 7.5
- Mar 11, 2026WP Maps: Time-based blind SQL InjectionCVE-2026-3222 · affects up to 4.9.1 · reported by WordfenceHigh 7.5
- Feb 16, 2026WP Maps – Store Locator,Google Maps,OpenStreetMap,Mapbox,Listing,Directory & Filters: Local File InclusionCVE-2025-12062 · affects up to 4.8.6 · reported by WordfenceHigh 8.8
- Dec 9, 2025WP Maps: Deserialization of Untrusted DataCVE-2025-67535 · affects up to 4.8.6 · reported by PatchstackMedium 6.6
- May 1, 2025WP Maps: Does not sanitise and escape some of its Map settingsCVE-2025-3504 · fixed in 4.7.2 · reported by WPScanMedium 4.8
- May 1, 2025WP Maps: Does not sanitise and escape some of its Map settingsCVE-2025-3503 · fixed in 4.7.2 · reported by WPScanMedium 4.8
- May 1, 2025WP Maps: Does not sanitise and escape some of its Map settingsCVE-2025-3502 · fixed in 4.7.2 · reported by WPScanMedium 4.8
- Jun 29, 2024WordPress Plugin for Google Maps – WP MAPS: SQL InjectionCVE-2024-2386 · affects up to 4.6.1 · reported by WordfenceHigh 8.8
- Nov 12, 2023flippercode WordPress Plugin for Google Maps – WP MAPS: Cross-Site Request Forgery (CSRF)CVE-2023-28172 · affects up to 4.4.2 · reported by PatchstackMedium 5.4
- Apr 4, 2023Auth.CVE-2023-23878 · fixed in 4.4.0 · reported by PatchstackMedium 5.9
- Mar 11, 2022Cross-Site Request Forgery (CSRF) vulnerability affecting Delete Marker Category, Delete Map, and Copy Map functions in WP Google Map plugin (versions <= 4.2.3)CVE-2022-25600 · affects up to 4.2.3 · reported by PatchstackMedium 5.4
- Aug 14, 2019The wp-google-map-plugin plugin before 2.3.10 for WordPress has CSRF in the add/edit category feature.CVE-2015-9309 · fixed in 2.3.10 · reported by MITREHigh 8.8
- Aug 14, 2019The wp-google-map-plugin plugin before 2.3.10 for WordPress has CSRF in the add/edit map feature.CVE-2015-9308 · fixed in 2.3.10 · reported by MITREHigh 8.8
- Aug 14, 2019The wp-google-map-plugin plugin before 2.3.10 for WordPress has CSRF in the add/edit location feature.CVE-2015-9307 · fixed in 2.3.10 · reported by MITREHigh 8.8
- Aug 12, 2019The wp-google-map-plugin plugin before 3.1.2 for WordPress has XSS.CVE-2016-10878 · fixed in 3.1.2 · reported by MITREMedium 6.1
- Aug 12, 2019The wp-google-map-plugin plugin before 2.3.7 for WordPress has XSS related to the add_query_arg() and remove_query_arg() functions.CVE-2015-9305 · fixed in 2.3.7 · reported by MITRE1.0% oddsMedium 6.1
- May 14, 2018WP Google Map Plugin prior to version 4.0.4 for: Cross-site scriptingCVE-2018-0577 · fixed in 4.0.4 · reported by vultures@jpcert.or.jpMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.