WordPress plugin · wp-front-end-profile
Is WP Frontend Profile safe?
A flaw affects the current version.
The newest release on wordpress.org, 1.3.9, is inside the affected range of CVE-2026-39688, so there may be no fix yet. Check the changelog; if it doesn’t mention the fix, deactivate it until it does.
- Flaws on record
- 5
- High or critical
- 2
- Exploited
- none
- Current version
- 1.3.9
- Last updated
- Feb 21, 2026
- Active installs
- 100+
Every recorded flaw
- Apr 8, 2026WP Frontend Profile: Missing AuthorizationCVE-2026-39688 · affects up to 1.3.9 · reported by PatchstackMedium 5.3
- Mar 6, 2026WP Frontend Profile: Cross-Site Request ForgeryCVE-2026-1644 · affects up to 1.3.8 · reported by WordfenceMedium 4.3
- May 17, 2024WP Frontend Profile: Improper Privilege ManagementCVE-2023-51483 · affects up to 1.3.1 · reported by PatchstackCritical 9.8
- Aug 21, 2019The wp-front-end-profile plugin before 0.2.2 for WordPress has a privilege escalation issue.CVE-2019-15111 · fixed in 0.2.2 · reported by MITRE2.1% oddsCritical 9.8
- Aug 21, 2019The wp-front-end-profile plugin before 0.2.2 for WordPress has XSS.CVE-2019-15110 · fixed in 0.2.2 · reported by MITREMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.