WordPress plugin · wp-easy-pay
Is WP Easy Pay safe?
Safe on 4.5.5 or newer.
The current version, 4.5.5, is past every affected range on record (12 of 12 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 12
- High or critical
- 0
- Exploited
- none
- Current version
- 4.5.5
- Last updated
- Oct 14, 2026
- Active installs
- 1,000+
Every recorded flaw
- Oct 15, 2026WP EasyPay: Missing AuthorizationCVE-2026-96449 · affects up to 4.5.4 · reported by PatchstackMedium 5.3
- Sep 18, 2026WP Easy Pay – Payment and Donation form Builder for Square: Authorization bypassCVE-2026-12739 · affects up to 4.5.0 · reported by WordfenceMedium 4.3
- Sep 3, 2026Unauthenticated Bypass Vulnerability in WP EasyPay <= 4.5.3 versions.CVE-2026-84762 · affects up to 4.5.3 · reported by PatchstackMedium 5.3
- Jul 23, 2026Subscriber Arbitrary Content Deletion in WP EasyPay <= 4.5.0 versions.CVE-2026-57808 · affects up to 4.5.0 · reported by PatchstackMedium 6.5
- Jul 11, 2026WP Easy Pay – Payment and Donation form Builder for Square: Authorization bypassCVE-2026-12738 · affects up to 4.5.0 · reported by WordfenceMedium 4.3
- Jun 18, 2026WP EasyPay: Cross-Site Request Forgery (CSRF)CVE-2026-56024 · affects up to 4.5.0 · reported by PatchstackMedium 6.5
- May 12, 2026WP EasyPay: Insertion of Sensitive Information Into Sent DataCVE-2026-45215 · affects up to 4.3.0 · reported by PatchstackMedium 5.3
- Mar 16, 2026WP EasyPay: Missing AuthorizationCVE-2026-32587 · affects up to 4.2.11 · reported by PatchstackMedium 5.4
- Jul 24, 2024WP EasyPay – Square for: Unauthorized modification of datadue to a missing capability check on the wpep_square_disconnect() functionCVE-2024-5861 · affects up to 4.2.3 · reported by WordfenceMedium 5.3
- Aug 16, 2023WP EasyPay: Does not escape some generated URLs before outputting them back in pagesCVE-2023-1465 · fixed in 4.1 · reported by WPScanMedium 6.1
- Jul 12, 2023WP EasyPay – Square for: Cross-Site Request ForgeryCVE-2021-4411 · affects up to 3.2.0 · reported by WordfenceMedium 4.3
- May 25, 2023Cross-Site Request Forgery (CSRF) vulnerability in WP Easy Pay WP EasyPay – Square for WordPress plugin <= 4.1 versions.CVE-2022-47177 · affects up to 4.1 · reported by PatchstackMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.