WordPress plugin · wp-base-booking-of-appointments-services-and-events
Is WP BASE Booking of Appointments, Services and Events safe?
Safe on 6.5.2 or newer.
The current version, 6.5.2, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 6
- Exploited
- none
- Current version
- 6.5.2
- Last updated
- Oct 12, 2026
- Active installs
- 100+
Every recorded flaw
- Oct 5, 2026WP BASE Booking: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-103066 · affects up to 6.4.0 · reported by PatchstackHigh 8.5
- Oct 5, 2026WP BASE Booking: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-103352 · affects up to 6.4.0 · reported by PatchstackCritical 9.3
- Aug 20, 2026Subscriber Cross Site Scripting (XSS) in WP BASE Booking <= 6.3.2 versions.CVE-2026-73402 · affects up to 6.3.2 · reported by PatchstackMedium 6.5
- Aug 13, 2026Unauthenticated Arbitrary Code Execution in WP BASE Booking <= 6.3.0 versions.CVE-2026-61962 · affects up to 6.3.0 · reported by PatchstackCritical 10
- Jul 23, 2026Subscriber Privilege Escalation in WP BASE Booking <= 6.3.1 versions.CVE-2026-59541 · affects up to 6.3.1 · reported by PatchstackHigh 8.8
- Jun 15, 2026Unauthenticated Privilege Escalation in WP BASE Booking <= 5.9.0 versions.CVE-2026-39587 · affects up to 5.9.0 · reported by PatchstackHigh 8.1
- Feb 26, 2025WP BASE Booking of Appointments, Services and Events: Does not sanitise and escape a parameter before outputting it back in the pageCVE-2024-12737 · fixed in 5.0.0 · reported by WPScanMedium 6.1
- Feb 3, 2025WP BASE Booking: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-22684 · affects up to 5.0.0 · reported by PatchstackHigh 7.1
- Dec 21, 2024WP BASE Booking of Appointments, Services and Events: Unauthorized access of dataCVE-2024-12558 · affects up to 4.9.2 · reported by Wordfence1.3% oddsMedium 6.5
- Dec 17, 2024WP BASE Booking of Appointments, Services and Events: Reflected Cross-Site ScriptingCVE-2024-12469 · affects up to 4.9.1 · reported by WordfenceMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.