WordPress plugin · wp-2fa
Is WP 2FA safe?
Safe on 4.2.1 or newer.
The current version, 4.2.1, is past every affected range on record (12 of 12 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 12
- High or critical
- 4
- Exploited
- none
- Current version
- 4.2.1
- Last updated
- Oct 14, 2026
- Active installs
- 100,000+
Every recorded flaw
- Oct 14, 2026WP 2FA: Does not perform an object-level capability check before removing a user's two-factor authentication configurationCVE-2026-108066 · fixed in 4.2.0 · reported by WPScanLow 2.7
- Oct 8, 2026WP 2FA: Cross-Site Request Forgery (CSRF)CVE-2026-62142 · affects up to 4.1.0 · reported by PatchstackHigh 8.8
- Oct 3, 2026WP 2FA: Does not invalidate a time-based one-time passcode once it has been usedCVE-2026-103514 · fixed in 4.1.0 · reported by WPScanHigh 7.5
- Aug 5, 2026WP 2FA: Does not validate the second authentication factorCVE-2026-15372 · fixed in 4.1.0 · reported by WPScanHigh 7.5
- Jul 14, 2026WP 2FA: Does not verify that the email address supplied during two-factor authentication setup belongs to the userCVE-2026-12988 · fixed in 3.1.1.2 · reported by WPScanMedium 6.4
- Jun 21, 2024WP 2FA: Insertion of Sensitive Information into Log FileCVE-2022-44587 · affects up to 2.6.3 · reported by PatchstackMedium 5.3
- Apr 18, 2024WP 2FA: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-32568 · affects up to 2.6.2 · reported by PatchstackHigh 7.1
- Mar 21, 2024WP 2FA: Improper AuthenticationCVE-2022-44595 · affects up to 2.2.0 · reported by PatchstackMedium 5.3
- Jan 11, 2024WP 2FA – Two-factor authentication for: Cross-Site Request ForgeryCVE-2023-6520 · affects up to 2.5.0 · reported by WordfenceMedium 4.3
- Jan 11, 2024WP 2FA – Two-factor authentication for: Insecure Direct Object ReferenceCVE-2023-6506 · affects up to 2.5.0 · reported by WordfenceMedium 4.3
- Oct 10, 2022WP 2FA: Uses comparison operators that don't mitigate time-based attacksCVE-2022-2891 · fixed in 2.3.0 · reported by WPScanMedium 5.9
- May 30, 2022WP 2FA: Does not sanitise and escape a parameter before outputting it back in an admin pageCVE-2022-1527 · fixed in 2.2.1 · reported by WPScanMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.