WordPress plugin · wordpress-seo
Is Yoast SEO safe?
Safe on 28.8 or newer.
The current version, 28.8, is past every affected range on record (14 of 14 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 14
- High or critical
- 1
- Exploited
- none
- Current version
- 28.8
- Last updated
- Oct 27, 2026
- Active installs
- 10,000,000+
Every recorded flaw
- Jul 25, 2026Yoast SEO – Advanced SEO with real-time guidance and built-in AI: Stored Cross-Site ScriptingCVE-2026-15425 · affects up to 28.0 · reported by WordfenceMedium 6.4
- May 27, 2026Yoast SEO: Insecure Direct Object ReferencesCVE-2025-14481 · affects up to 26.5 · reported by WordfenceMedium 4.3
- Mar 22, 2026Yoast SEO – Advanced SEO with real-time guidance and built-in AI: Stored Cross-Site ScriptingCVE-2026-3427 · affects up to 27.1.1 · reported by WordfenceMedium 6.4
- Feb 6, 2026Yoast SEO – Advanced SEO with real-time guidance and built-in AI: Stored Cross-Site ScriptingCVE-2026-1293 · affects up to 26.8 · reported by WordfenceMedium 6.4
- May 15, 2024Yoast SEO: Stored Cross-Site ScriptingCVE-2024-4984 · affects up to 22.6 · reported by WordfenceMedium 6.4
- May 14, 2024Yoast SEO: Reflected Cross-Site ScriptingCVE-2024-4041 · affects up to 22.5 · reported by WordfenceMedium 6.1
- Nov 30, 2023Yoast SEO: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-40680 · affects up to 21.0 · reported by PatchstackMedium 5.9
- Apr 5, 2021A Stored Cross-Site Scripting vulnerability was discovered in the Yoast SEO WordPress plugin before 3.4.1, which had built-in blacklist filters which were blackCVE-2021-24153 · fixed in 3.4.1 · reported by WPScan1.1% oddsMedium 5.4
- Jul 9, 2019The Yoast SEO plugin before 11.6-RC5 for WordPress does not properly restrict unfiltered HTML in term descriptions.CVE-2019-13478 · fixed in 11.6-RC5 · reported by MITRE3.3% oddsCritical 9.8
- Nov 28, 2018A Race condition vulnerability in unzip_file in admin/import/class-import-settings.php in the Yoast SEO (wordpress-seo) plugin before 9.2.0 for WordPress allowsCVE-2018-19370 · fixed in 9.2.0 · reported by MITRE3.2% oddsMedium 6.6
- Nov 15, 2017Cross-site scripting (XSS) vulnerability in admin/google_search_console/class-gsc-table.php in the Yoast SEO plugin before 5.8.0 for WordPress allows remote attCVE-2017-16842 · fixed in 5.8.0 · reported by MITRE1.3% oddsMedium 4.8
- Jun 17, 2015Cross-site scripting (XSS) vulnerability in js/wp-seo-metabox.js in the WordPress SEO by Yoast plugin before 2.2 for WordPress allows remote attackers to injectCVE-2012-6692 · fixed in 2.2 · reported by MITRE3.2% oddsMedium 4.3
- Mar 17, 2015Multiple cross-site request forgery (CSRF) vulnerabilities in admin/class-bulk-editor-list-table.php in the WordPress SEO by Yoast plugin before 1.5.7, 1.6.x beCVE-2015-2293 · fixed in 1.5.7 · reported by MITRE1.5% oddsMedium 6.8
- Mar 17, 2015Multiple SQL injection vulnerabilities in admin/class-bulk-editor-list-table.php in the WordPress SEO by Yoast plugin before 1.5.7, 1.6.x before 1.6.4, and 1.7.CVE-2015-2292 · fixed in 1.5.7 · reported by MITRE5.6% oddsMedium 6.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.