WordPress plugin · woocommerce-jetpack
Is Booster for WooCommerce safe?
Safe on 8.5.1 or newer.
The current version, 8.5.1, is past every affected range on record (27 of 29 records list one; 2 don’t, so check those below). Keep it updated and you’re clear of them.
- Flaws on record
- 29
- High or critical
- 10
- Exploited
- none
- Current version
- 8.5.1
- Last updated
- Oct 15, 2026
- Active installs
- 30,000+
Every recorded flaw
- Oct 10, 2026Unauthenticated PHP Object Injection in Booster for WooCommerce <= 8.4.0 versions.CVE-2026-42718 · affects up to 8.4.0 · reported by PatchstackCritical 9.8
- Jun 26, 2026Customer Arbitrary File Upload in Booster for WooCommerce <= 8.0.1 versions.CVE-2026-56027 · reported by PatchstackCritical 9.9
- Mar 17, 2026Booster for WooCommerce: Missing AuthorizationCVE-2026-32586 · reported by PatchstackMedium 5.3
- Nov 13, 2025Booster for WooCommerce: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-64380 · affects up to 7.3.2 · reported by PatchstackMedium 6.5
- Nov 13, 2025Booster for WooCommerce: Missing AuthorizationCVE-2025-64379 · affects up to 7.4.0 · reported by PatchstackMedium 4.3
- Nov 6, 2025Booster for WooCommerce: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-64196 · affects up to 7.2.5 · reported by PatchstackHigh 7.1
- Aug 29, 2025Booster for WooCommerce: Arbitrary file uploadsCVE-2024-13342 · affects up to 7.2.4 · reported by WordfenceHigh 8.1
- Apr 4, 2025Booster for WooCommerce: Stored Cross-Site ScriptingCVE-2024-13708 · affects 4.0.1 to 7.2.4 · reported by WordfenceHigh 7.2
- Apr 4, 2025Booster for WooCommerce: Arbitrary file uploadsCVE-2024-13744 · affects 4.0.1 to 7.2.4 · reported by WordfenceHigh 8.1
- Apr 1, 2025Booster for WooCommerce: Stored Cross-Site ScriptingCVE-2024-12278 · affects up to 7.2.4 · reported by WordfenceHigh 7.2
- Nov 26, 2024Booster for WooCommerce: Stored Cross-Site ScriptingCVE-2024-9170 · affects up to 7.2.3 · reported by WordfenceMedium 5.5
- Nov 20, 2024Booster for WooCommerce: Reflected Cross-Site ScriptingCVE-2024-9239 · affects up to 7.2.3 · reported by WordfenceMedium 6.1
- Jun 4, 2024Booster for WooCommerce: Improper AuthenticationCVE-2023-48747 · affects up to 7.1.2 · reported by PatchstackMedium 6.5
- May 2, 2024Booster for WooCommerce: Unauthenticated Arbitrary Shortcode ExecutionCVE-2024-3957 · affects up to 7.1.8 · reported by WordfenceMedium 6.5
- Mar 27, 2024Booster for WooCommerce: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29760 · affects up to 7.1.7 · reported by PatchstackHigh 7.1
- Mar 7, 2024Booster Elite for WooCommerce: Arbitrary file uploadsCVE-2024-1986 · affects up to 7.1.7 · reported by Wordfence1.3% oddsHigh 8.8
- Mar 7, 2024Booster for WooCommerce: Stored Cross-Site ScriptingCVE-2024-1534 · affects up to 7.1.7 · reported by WordfenceMedium 6.4
- Feb 28, 2024Booster for WooCommerce: Stored Cross-Site ScriptingCVE-2024-1054 · affects up to 7.1.6 · reported by WordfenceMedium 6.4
- Nov 30, 2023Booster for WooCommerce: Exposure of Sensitive Information to an Unauthorized ActorCVE-2023-48333 · affects up to 7.1.1 · reported by PatchstackMedium 6.5
- Nov 22, 2023Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Pluggabl LLC Booster for WooCommerce plugin <= 7.1.1 versions.CVE-2023-40002 · affects up to 7.1.1 · reported by PatchstackMedium 6.5
- Oct 20, 2023Booster for WooCommerce: Information DisclosureCVE-2023-4796 · affects up to 7.1.0 · reported by WordfenceMedium 4.3
- Oct 18, 2023Booster for WooCommerce: Stored Cross-Site ScriptingCVE-2023-5638 · affects up to 7.1.2 · reported by WordfenceMedium 6.4
- Sep 13, 2023Booster for WooCommerce: Stored Cross-Site ScriptingCVE-2023-4945 · affects up to 7.1.0 · reported by WordfenceMedium 6.4
- Nov 18, 2022Cross-Site Request Forgery (CSRF) vulnerability in Booster for WooCommerce plugin <= 5.6.6 on WordPress.CVE-2022-41805 · affects up to 5.6.6 · reported by PatchstackMedium 5.4
- Jan 3, 2022Booster for WooCommerce: Does not sanitise and escape the wcj_create_products_xml_result parameter before outputting back in the admin dashboardCVE-2021-25001 · fixed in 5.4.9 · reported by WPScanMedium 6.1
- Jan 3, 2022Booster for WooCommerce: Does not sanitise and escape the wcj_delete_role parameter before outputting back in the admin dashboardCVE-2021-25000 · fixed in 5.4.9 · reported by WPScanMedium 6.1
- Jan 3, 2022Booster for WooCommerce: Does not sanitise and escape the wcj_notice parameter before outputting it back in the admin dashboardCVE-2021-24999 · fixed in 5.4.9 · reported by WPScanMedium 6.1
- Aug 30, 2021Versions up to, and including, 5.4.3, of the Booster for WooCommerce WordPress plugin are vulnerable to authentication bypass via the process_email_verificationCVE-2021-34646 · affects up to 5.4.3 · reported by Wordfence51% oddsCritical 9.8
- Aug 12, 2019The woocommerce-jetpack plugin before 3.8.0 for WordPress has XSS in the Products Per Page feature.CVE-2018-20966 · fixed in 3.8.0 · reported by MITRE1.8% oddsMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.