WordPress plugin · woocommerce-currency-switcher
Is FOX safe?
Safe on 1.5.6 or newer.
The current version, 1.5.6, is past every affected range on record (15 of 16 records list one; 1 doesn’t, so check it below). Keep it updated and you’re clear of them.
- Flaws on record
- 16
- High or critical
- 5
- Exploited
- none
- Current version
- 1.5.6
- Last updated
- Oct 24, 2026
- Active installs
- 50,000+
Every recorded flaw
- Oct 13, 2026FOX: Missing AuthorizationCVE-2026-108174 · affects up to 1.5.4 · reported by PatchstackMedium 5.3
- Jun 26, 2026Unauthenticated Cross Site Scripting (XSS) in FOX <= 1.4.8 versions.CVE-2026-57319 · reported by PatchstackHigh 7.1
- May 28, 2026FOX – Currency Switcher Professional for WooCommerce: Authorization Bypass Through User-Controlled KeyCVE-2026-9241 · affects up to 1.4.6 · reported by WordfenceMedium 4.3
- May 15, 2026FOX – Currency Switcher Professional for WooCommerce: Unauthorized data lossCVE-2026-4094 · affects up to 1.4.5 · reported by WordfenceHigh 8.1
- Apr 8, 2026FOX: Missing AuthorizationCVE-2026-39501 · affects up to 1.4.5 · reported by PatchstackMedium 5.3
- Apr 8, 2026FOX: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-39497 · affects up to 1.4.5 · reported by PatchstackHigh 7.6
- Nov 9, 2024The FOX – Currency Switcher Professional for WooCommerce: Arbitrary shortcode executionCVE-2024-10640 · affects up to 1.4.2.2 · reported by WordfenceHigh 7.3
- Sep 13, 2024The FOX – Currency Switcher Professional for WooCommerce: Arbitrary shortcode executionCVE-2024-8271 · affects up to 1.4.2.1 · reported by WordfenceHigh 7.3
- May 2, 2024FOX – Currency Switcher Professional for WooCommerce: Unauthenticated Arbitrary Shortcode ExecutionCVE-2024-3734 · affects up to 1.4.1.8 · reported by Wordfence1.0% oddsMedium 6.5
- Mar 29, 2024WOOCS – WooCommerce Currency Switcher: Cross-Site Request Forgery (CSRF)CVE-2024-30458 · affects up to 1.4.1.7 · reported by PatchstackMedium 4.3
- Jan 11, 2024FOX – Currency Switcher Professional for WooCommerce: Stored Cross-Site ScriptingCVE-2023-6556 · affects up to 1.4.1.5 · reported by WordfenceMedium 5.4
- Dec 17, 2023FOX – Currency Switcher Professional for WooCommerce: Cross-Site Request Forgery (CSRF)CVE-2023-49834 · affects up to 1.4.1.4 · reported by PatchstackMedium 5.4
- Jan 16, 2023WOOCS: Does not validate and escape some of its shortcode attributes before outputting them back in the pageCVE-2022-4431 · fixed in 1.3.9.4 · reported by WPScanMedium 5.4
- Feb 21, 2022WOOCS: Does not sanitise and escape the woocs_in_order_currency parameter of the woocs_get_products_price_html AJAX action (available to both unauthenticated and authenticated users) before outputting it back in the respCVE-2022-0234 · fixed in 1.3.7.5 · reported by WPScan1.8% oddsMedium 6.1
- Jan 10, 2022WOOCS: Does not sanitise and escape the custom_prices parameter before outputting it back in the responseCVE-2021-25043 · fixed in 1.3.7.3 · reported by WPScanMedium 6.1
- Dec 6, 2021WOOCS: Does not sanitise and escape the key parameter of the woocs_update_profiles_data AJAX action (available to any authenticated user) before outputting it back in the responseCVE-2021-24938 · fixed in 1.3.7.1 · reported by WPScanMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.