WordPress plugin · woocommerce
Is WooCommerce safe?
Safe on 11.2.1 or newer.
The current version, 11.2.1, is past every affected range on record (20 of 22 records list one; 2 don’t, so check those below). Keep it updated and you’re clear of them.
- Flaws on record
- 22
- High or critical
- 5
- Exploited
- none
- Current version
- 11.2.1
- Last updated
- Oct 9, 2026
- Active installs
- 7,000,000+
Every recorded flaw
- Oct 10, 2026WooCommerce: Incorrect Privilege AssignmentCVE-2026-106608 · affects up to 11.1.2 · reported by PatchstackHigh 7.2
- Sep 8, 2026WooCommerce: Allocation of Resources Without Limits or ThrottlingCVE-2026-48888 · fixed in 11.1.0 · reported by PatchstackHigh 7.5
- Sep 4, 2026WooCommerce: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-57777 · fixed in 11.0 · reported by PatchstackHigh 7.6
- Jun 20, 2026WooCommerce 7.1.0 contains a remote code execution vulnerability that allows attackers to execute arbitrary PHP code by injecting shell commands through the proCVE-2022-50972 · reported by VulnCheck1.1% oddsCritical 9.3
- Oct 29, 2025WooCommerce: Sensitive Information ExposureCVE-2023-7320 · affects up to 7.8.2 · reported by WordfenceMedium 5.3
- Oct 29, 2025WooCommerce: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-49042 · affects up to 10.0.2 · reported by PatchstackMedium 5.9
- May 22, 2025WooCommerce: PostMessage-Based Cross-Site ScriptingCVE-2025-5062 · affects up to 9.4.2 · reported by WordfenceMedium 6.1
- Mar 27, 2025WooCommerce: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-26762 · affects up to 9.7.0 · reported by PatchstackMedium 5.9
- Oct 15, 2024WooCommerce: HTML InjectionCVE-2024-9944 · affects up to 9.0.2 · reported by WordfenceMedium 5.3
- Aug 18, 2024WooCommerce: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-39666 · affects up to 9.1.2 · reported by PatchstackMedium 5.9
- Jul 9, 2024WooCommerce: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')CVE-2024-35777 · affects up to 8.9.2 · reported by PatchstackLow 3.5
- Apr 15, 2024WooCommerce: Does not prevent users with at least the contributor role from leaking products they shouldn't have access toCVE-2024-1310 · fixed in 8.6 · reported by WPScanMedium 4.9
- Apr 7, 2024WooCommerce: Cross-Site Request Forgery (CSRF)CVE-2024-22155 · affects up to 8.5.2 · reported by PatchstackMedium 4.3
- Jan 16, 2024WooCommerce: Does not have proper authorisation checkCVE-2022-0775 · fixed in 6.2.1 · reported by WPScanMedium 4.3
- Jan 8, 2024WooCommerce: Cross-Site Request Forgery (CSRF)CVE-2023-52222 · affects up to 8.2.2 · reported by PatchstackMedium 4.3
- Jul 17, 2022The WooCommerce WordPress plugin before 6.6.0 is vulnerable to stored HTML injection due to lack of escaping and sanitizing in the payment gateway titlesCVE-2022-2099 · fixed in 6.6.0 · reported by WPScanMedium 4.8
- Dec 27, 2020The WooCommerce plugin before 4.7.0 for WordPress allows remote attackers to view the status of arbitrary orders via the order_id parameter in a fetch_order_staCVE-2020-29156 · fixed in 4.7.0 · reported by MITRE4.0% oddsMedium 5.3
- Feb 8, 2018Cross-site scripting (XSS) vulnerability in the WooCommerce plugin before 2.3.6 for WordPress allows remote attackers to inject arbitrary web script or HTML viaCVE-2015-2329 · fixed in 2.3.6 · reported by MITRE1.2% oddsMedium 6.1
- Nov 29, 2017The WooCommerce plugin through 3.x for WordPress has a Directory Traversal Vulnerability via a /wp-content/plugins/woocommerce/templates/emails/plain/ URI, whicCVE-2017-17058 · affects up to 3.x · reported by MITRE24% oddsHigh 7.5
- Jan 3, 2017Cross-site scripting (XSS) vulnerability in the WooCommerce plugin before 2.6.9 for WordPress allows remote authenticated administrators to inject arbitrary webCVE-2016-10112 · fixed in 2.6.9 · reported by MITREMedium 4.8
- Feb 24, 2015Cross-site scripting (XSS) vulnerability in the WooCommerce plugin before 2.2.11 for WordPress allows remote attackers to inject arbitrary web script or HTML viCVE-2015-2069 · fixed in 2.2.11 · reported by MITRE2.0% oddsMedium 4.3
- Oct 14, 2014Cross-site scripting (XSS) vulnerability in the WooCommerce plugin before 2.2.3 for WordPress allows remote attackers to inject arbitrary web script or HTML viaCVE-2014-6313 · fixed in 2.2.3 · reported by MITRE2.0% oddsMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.