WordPress plugin · woo-wallet
Is Wallet for WooCommerce safe?
Safe on 1.7.3 or newer.
The current version, 1.7.3, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 2
- Exploited
- none
- Current version
- 1.7.3
- Last updated
- Oct 9, 2026
- Active installs
- 20,000+
Every recorded flaw
- Aug 12, 2026Wallet for WooCommerce: Does not verify the amount actually collected for a wallet top-up before crediting the walletCVE-2026-16538 · fixed in 1.6.10 · reported by WPScanCritical 9.1
- Jul 11, 2026Wallet for WooCommerce: Authorization bypassCVE-2026-12103 · affects up to 1.6.4 · reported by WordfenceMedium 4.3
- Mar 13, 2026TeraWallet – For WooCommerce: Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')CVE-2026-32398 · affects up to 1.5.15 · reported by PatchstackMedium 6.5
- Nov 28, 2024Wallet for WooCommerce: Incorrect conversion between numeric typesCVE-2024-7747 · affects up to 1.5.6 · reported by WordfenceMedium 6.5
- Jul 12, 2024Wallet for WooCommerce: SQL InjectionCVE-2024-6353 · affects up to 1.5.4 · reported by WordfenceHigh 8.8
- Apr 18, 2024TeraWallet – For WooCommerce: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-32584 · affects up to 1.5.0 · reported by PatchstackMedium 5.9
- Mar 13, 2024TeraWallet – Best WooCommerce Wallet System With Cashback Rewards, Partial Payment, Wallet Refunds: Unauthorized access of dataCVE-2024-1690 · affects up to 1.4.10 · reported by WordfenceMedium 4.3
- Mar 1, 2023Cross-Site Request Forgery (CSRF) vulnerability in StandaloneTech TeraWallet – For WooCommerce plugin <= 1.3.24 leading to plugin settings change.CVE-2022-40198 · affects up to 1.3.24 · reported by PatchstackMedium 4.3
- Feb 2, 2023Cross-Site Request Forgery (CSRF) vulnerability in TeraWallet – For WooCommerce plugin <= 1.3.24 versions.CVE-2022-36401 · fixed in 1.4.0 · reported by PatchstackMedium 5.4
- Nov 29, 2022TeraWallet: Insecure Direct Object ReferenceCVE-2022-3995 · affects up to 1.4.3 · reported by WordfenceMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.