WordPress plugin · wc-multivendor-marketplace
Is WCFM Marketplace safe?
Safe on 3.8.3 or newer.
The current version, 3.8.3, is past every affected range on record (14 of 14 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 14
- High or critical
- 6
- Exploited
- none
- Current version
- 3.8.3
- Last updated
- Aug 30, 2026
- Active installs
- 10,000+
Every recorded flaw
- Sep 18, 2026WCFM Marketplace – Multivendor Marketplace for WooCommerce: Generic SQL InjectionCVE-2026-18442 · affects up to 3.8.2 · reported by WordfenceHigh 7.5
- Sep 2, 2026Contributor Cross Site Scripting (XSS) in WCFM Marketplace <= 3.8.2 versions.CVE-2026-83562 · affects up to 3.8.2 · reported by PatchstackMedium 6.5
- Sep 2, 2026Unauthenticated SQL Injection in WCFM Marketplace <= 3.8.1 versions.CVE-2026-81286 · affects up to 3.8.1 · reported by PatchstackCritical 9.3
- Aug 28, 2026WCFM Marketplace: Does not correctly verify that the person requesting a refund owns the orderCVE-2026-77701 · fixed in 3.8.2 · reported by WPScanMedium 5.3
- Aug 19, 2026WCFM Marketplace: Does not verify that a marketplace vendor owns a review before allowing it to be unapproved or deletedCVE-2026-14196 · fixed in 3.8.1 · reported by WPScanMedium 4.3
- Jul 11, 2026WCFM Marketplace – Multivendor Marketplace for WooCommerce: Stored Cross-Site ScriptingCVE-2026-12126 · affects up to 3.7.3 · reported by WordfenceMedium 6.4
- Apr 15, 2026WCFM Marketplace: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-63029 · affects up to 3.7.1 · reported by PatchstackHigh 7.6
- Feb 10, 2026WCFM Marketplace – Multivendor Marketplace for WooCommerce: Insecure Direct Object ReferenceCVE-2026-1722 · affects up to 3.7.0 · reported by WordfenceMedium 5.3
- Dec 16, 2025WCFM Marketplace: Missing AuthorizationCVE-2025-64631 · affects up to 3.7.1 · reported by PatchstackMedium 4.9
- Sep 17, 2024WCFM Marketplace: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-44009 · affects up to 3.6.11 · reported by PatchstackHigh 7.1
- Jan 11, 2024WCFM Marketplace: Stored Cross-Site ScriptingCVE-2023-4960 · affects up to 3.6.2 · reported by WordfenceMedium 6.4
- Apr 5, 2023WCFM Marketplace: Cross-Site Request ForgeryCVE-2022-4936 · affects up to 3.4.11 · reported by WordfenceMedium 6.3
- Apr 5, 2023WCFM Marketplace: Unauthorized modification and access of dataCVE-2022-4935 · affects up to 3.4.11 · reported by WordfenceHigh 8.8
- Dec 21, 2021The wcfm_ajax_controller AJAX action of the WCFM Marketplace WordPress plugin before 3.4.12, available to unauthenticated and authenticated user, does not propeCVE-2021-24849 · fixed in 3.4.12 · reported by WPScan8.4% oddsCritical 9.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.