WordPress plugin · wallet-system-for-woocommerce
Is Wallet System for WooCommerce safe?
Safe on 2.8.2 or newer.
The current version, 2.8.2, is past every affected range on record (14 of 15 records list one; 1 doesn’t, so check it below). Keep it updated and you’re clear of them.
- Flaws on record
- 15
- High or critical
- 4
- Exploited
- none
- Current version
- 2.8.2
- Last updated
- Oct 21, 2026
- Active installs
- 1,000+
Every recorded flaw
- Oct 8, 2026Wallet System for WooCommerce: Does not validate that a wallet transfer amount is positiveCVE-2026-93509 · fixed in 2.8.0 · reported by WPScanMedium 6.5
- Oct 8, 2026Wallet System for WooCommerce: Does not verify that the wallet account named in a withdrawal submission belongs to the user making itCVE-2026-94246 · fixed in 2.8.0 · reported by WPScanMedium 6.3
- Oct 8, 2026Wallet System for WooCommerce: Does not verify that the user submitting a wallet transfer owns the wallet being debitedCVE-2026-94245 · fixed in 2.8.0 · reported by WPScanMedium 6.5
- Oct 8, 2026Wallet System for WooCommerce: Does not perform any capability checkCVE-2026-94244 · fixed in 2.8.0 · reported by WPScanMedium 4.3
- Aug 12, 2026Wallet System for WooCommerce: Does not validate a user-supplied wallet amount against the customer's actual stored balance during checkoutCVE-2026-15045 · fixed in 2.7.10 · reported by WPScanMedium 6.5
- Jun 29, 2026Subscriber Broken Access Control in Wallet System for WooCommerce <= 2.7.6 versions.CVE-2026-57332 · reported by PatchstackHigh 7.1
- Jun 2, 2026Wallet System for WooCommerce: Authentication Bypass Using an Alternate Path or ChannelCVE-2026-42654 · affects up to 2.7.5 · reported by PatchstackHigh 7.1
- Jan 16, 2026Wallet System for WooCommerce: Unauthorized modification of dataCVE-2025-14450 · affects up to 2.7.2 · reported by WordfenceMedium 6.5
- Jan 5, 2026Wallet System for WooCommerce: Insertion of Sensitive Information Into Sent DataCVE-2025-68029 · affects up to 2.7.3 · reported by PatchstackMedium 6.3
- Jul 16, 2025Wallet System for WooCommerce: Cross-Site Request Forgery (CSRF)CVE-2025-54041 · affects up to 2.6.7 · reported by PatchstackMedium 4.3
- Apr 17, 2025Wallet System for WooCommerce: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-32530 · affects up to 2.6.8 · reported by PatchstackHigh 7.1
- Mar 4, 2025Wallet System for WooCommerce – Wallet, Wallet Cashback, Refunds, Partial Payment, Wallet Restriction: Unauthorized access to functionalityCVE-2024-13724 · affects up to 2.6.2 · reported by WordfenceMedium 4.3
- Mar 4, 2025Wallet System for WooCommerce – Wallet, Wallet Cashback, Refunds, Partial Payment, Wallet Restriction: Cross-Site Request ForgeryCVE-2024-13682 · affects up to 2.6.2 · reported by WordfenceMedium 4.3
- Aug 13, 2024Wallet System for WooCommerce: Missing AuthorizationCVE-2024-38699 · affects up to 2.5.13 · reported by PatchstackHigh 7.5
- Apr 15, 2024Wallet System for WooCommerce: Cross-Site Request Forgery (CSRF)CVE-2024-32446 · affects up to 2.5.9 · reported by PatchstackMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.