WordPress plugin · vk-all-in-one-expansion-unit
Is VK All in One Expansion Unit safe?
Safe on 9.123.1 or newer.
The current version, 9.123.1, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 0
- Exploited
- none
- Current version
- 9.123.1
- Last updated
- Sep 5, 2026
- Active installs
- 100,000+
Every recorded flaw
- Sep 18, 2026VK All in One Expansion Unit: Stored Cross-Site ScriptingCVE-2026-17586 · affects up to 9.118.0 · reported by WordfenceMedium 6.4
- Apr 8, 2026VK All in One Expansion Unit: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2026-39483 · affects up to 9.113.3 · reported by PatchstackMedium 6.5
- Feb 18, 2026VK All in One Expansion Unit: Stored Cross-Site ScriptingCVE-2025-11737 · affects up to 9.112.3 · reported by WordfenceMedium 6.4
- Nov 18, 2025VK All in One Expansion Unit: Stored Cross-Site ScriptingCVE-2025-11267 · affects up to 9.112.1 · reported by WordfenceMedium 6.4
- Nov 18, 2025VK All in One Expansion Unit: Stored Cross-Site ScriptingCVE-2025-11265 · affects up to 9.112.1 · reported by WordfenceMedium 6.4
- Jul 20, 2024VK All in One Expansion Unit: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-37956 · affects up to 9.99.1.0 · reported by PatchstackMedium 6.5
- Apr 9, 2024VK All in One Expansion Unit: Sensitive Information ExposureCVE-2024-2093 · affects up to 9.95.0.1 · reported by WordfenceMedium 6.5
- Mar 26, 2024VK All in One Expansion Unit: Stored Cross-Site ScriptingCVE-2024-2170 · affects up to 9.96.0.1 · reported by WordfenceMedium 6.4
- Mar 20, 2023VK All in One Expansion Unit: Does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attributeCVE-2023-0937 · fixed in 9.87.1.0 · reported by WPScanMedium 6.1
- Feb 27, 2023VK All in One Expansion Unit: Does not validate and escape some of its block options before outputting them back in a page/post where the block is embedCVE-2023-0230 · fixed in 9.86.0.0 · reported by WPScanMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.