WordPress plugin · ultimate-post
Is Post Grid Blocks & Templates for News, Magazine, & Blog Sites safe?
Closed. Replace it.
wordpress.org closed it on Oct 10, 2026, so it gets no more security fixes, and 25 flaws are on record. If your site runs it, move to a maintained alternative.
- Flaws on record
- 25
- High or critical
- 9
- Exploited
- none
Every recorded flaw
- Oct 10, 2026Post Grid Gutenberg Blocks – PostX: Stored Cross-Site ScriptingCVE-2026-96840 · affects up to 5.1.0 · reported by WordfenceHigh 7.2
- Sep 23, 2026Post Grid Gutenberg Blocks: Does not perform an authorization or post-visibility check on a REST API route that returns the custom field keys of a given postCVE-2026-86783 · fixed in 5.0.41 · reported by WPScanMedium 5.3
- Aug 6, 2026Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX: Stored Cross-Site ScriptingCVE-2026-5158 · affects up to 5.0.13 · reported by WordfenceMedium 6.4
- Jul 24, 2026Post Grid Gutenberg Blocks – PostX: Stored Cross-Site ScriptingCVE-2026-15100 · affects up to 5.0.32 · reported by WordfenceMedium 6.4
- Jul 9, 2026Ultimate Post: Stored Cross-Site ScriptingCVE-2026-13253 · affects up to 5.0.31 · reported by WordfenceMedium 6.4
- Apr 16, 2026Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX: Unauthorized modification of dataCVE-2026-0718 · affects up to 5.0.5 · reported by WordfenceMedium 5.3
- Mar 3, 2026Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX: Server-Side Request ForgeryCVE-2026-1273 · affects up to 5.0.8 · reported by WordfenceHigh 7.2
- Jan 22, 2026PostX: Missing AuthorizationCVE-2025-69313 · affects up to 5.0.3 · reported by PatchstackHigh 7.5
- Dec 24, 2025PostX: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2025-68606 · affects up to 5.0.3 · reported by PatchstackMedium 5.3
- Dec 20, 2025Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX: Unauthorized access of dataCVE-2025-12980 · affects up to 5.0.3 · reported by WordfenceHigh 7.5
- Dec 18, 2025PostX: Incorrect Privilege AssignmentCVE-2025-55707 · affects up to 4.1.35 · reported by PatchstackHigh 7.2
- Dec 18, 2025PostX: Missing AuthorizationCVE-2025-54751 · affects up to 4.1.36 · reported by PatchstackHigh 7.1
- Mar 28, 2025PostX: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-31096 · affects up to 4.1.25 · reported by PatchstackMedium 6.5
- Dec 9, 2024PostX: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-53818 · affects up to 4.1.15 · reported by PatchstackMedium 6.5
- Nov 19, 2024PostX: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-50513 · affects up to 4.1.15 · reported by PatchstackMedium 5.9
- Nov 16, 2024Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX: Unauthorized plugin installation/activationCVE-2024-10728 · affects up to 4.1.16 · reported by Wordfence39% oddsHigh 8.8
- Oct 28, 2024PostX: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-50443 · affects up to 4.1.12 · reported by PatchstackMedium 6.5
- Jun 17, 2024Post Grid Gutenberg Blocks and WordPress Blog: Does not validate and escape some of its block options before outputting them back in a page/post where the block is embedCVE-2024-4305 · fixed in 4.1.0 · reported by WPScanMedium 6.8
- Jun 9, 2024PostX: Missing AuthorizationCVE-2024-31246 · affects up to 3.2.3 · reported by PatchstackMedium 5.4
- May 30, 2024Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX: Unauthorized modification of dataCVE-2024-5326 · affects up to 4.1.2 · reported by Wordfence1.4% oddsHigh 8.8
- May 30, 2024Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX: Stored Cross-Site ScriptingCVE-2024-5223 · affects up to 4.1.1 · reported by WordfenceMedium 6.4
- May 14, 2024Post Grid Gutenberg Blocks and WordPress Blog: Does not validate and escape some of its block options before outputting them back in a page/post where the block is embedCVE-2024-3239 · fixed in 4.0.2 · reported by WPScanMedium 5.4
- Apr 18, 2024PostX: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-32564 · affects up to 4.0.1 · reported by PatchstackMedium 6.5
- Aug 30, 2023PostX: Does not sanitise and escape a parameter before outputting it back in the pageCVE-2023-3992 · fixed in 3.0.6 · reported by WPScanMedium 6.1
- Jul 25, 2023Unauth.CVE-2023-36385 · affects up to 2.9.9 · reported by PatchstackHigh 7.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.