WordPress plugin · ultimate-addons-for-gutenberg
Is Spectra Legacy safe?
Safe on 2.20.5 or newer.
The current version, 2.20.5, is past every affected range on record (27 of 27 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 27
- High or critical
- 2
- Exploited
- none
- Current version
- 2.20.5
- Last updated
- Oct 9, 2026
- Active installs
- 1,000,000+
Every recorded flaw
- Sep 24, 2026Spectra Legacy – Gutenberg Blocks: Sensitive Information ExposureCVE-2026-16302 · affects up to 2.20.0 · reported by WordfenceMedium 4.3
- Aug 1, 2026Spectra Legacy: Does not validate or escape several block style attributes before using them to build the CSS it outputs on the front endCVE-2026-10827 · fixed in 2.20.0 · reported by WPScanLow 3.5
- Jul 20, 2026Spectra Gutenberg Blocks – Website Builder for the Block Editor: Stored Cross-Site ScriptingCVE-2026-12900 · affects up to 2.19.28 · reported by WordfenceMedium 6.4
- May 30, 2026Spectra Gutenberg Blocks – Website Builder for the Block Editor: Remote Code ExecutionCVE-2026-7465 · affects up to 2.19.25 · reported by Wordfence1.2% oddsHigh 8.8
- Apr 29, 2026Spectra: Missing AuthorizationCVE-2026-42648 · affects up to 2.19.22 · reported by PatchstackMedium 4.3
- Feb 3, 2026Spectra: Missing AuthorizationCVE-2026-24982 · affects up to 2.19.17 · reported by PatchstackMedium 5.3
- Feb 3, 2026Spectra Gutenberg Blocks – Website Builder for the Block Editor: Information DisclosureCVE-2026-0950 · affects up to 2.19.17 · reported by WordfenceMedium 5.3
- Dec 9, 2025Spectra: Missing AuthorizationCVE-2023-23729 · affects up to 2.3.0 · reported by PatchstackMedium 5.4
- Nov 5, 2025Spectra Gutenberg Blocks – Website Builder for the Block Editor: Stored Cross-Site ScriptingCVE-2025-11162 · affects up to 2.19.14 · reported by WordfenceMedium 6.4
- Mar 26, 2025Spectra – WordPress Gutenberg Blocks: Stored Cross-Site ScriptingCVE-2025-1784 · affects up to 2.19.0 · reported by WordfenceMedium 6.4
- Dec 9, 2024Spectra: Missing AuthorizationCVE-2023-23834 · affects up to 2.3.0 · reported by PatchstackMedium 4.3
- Dec 9, 2024Spectra: Missing AuthorizationCVE-2023-23825 · affects up to 2.3.0 · reported by PatchstackLow 3.1
- Dec 3, 2024Spectra – WordPress Gutenberg Blocks: Stored Cross-Site ScriptingCVE-2024-10484 · affects up to 2.16.2 · reported by WordfenceMedium 6.4
- Nov 1, 2024Spectra: Missing AuthorizationCVE-2024-37517 · affects up to 2.13.7 · reported by PatchstackMedium 4.3
- Aug 12, 2024Spectra: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-7590 · affects up to 2.14.1 · reported by PatchstackMedium 6.5
- Jun 19, 2024Spectra: Missing AuthorizationCVE-2023-36676 · affects up to 2.6.6 · reported by PatchstackMedium 5.4
- Jun 3, 2024Spectra: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')CVE-2023-23738 · affects up to 2.3.0 · reported by PatchstackMedium 5.3
- Jun 3, 2024Spectra: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)CVE-2023-23735 · affects up to 2.3.0 · reported by PatchstackMedium 5.3
- Jun 3, 2024Spectra: Improper Restriction of Excessive Authentication AttemptsCVE-2023-23730 · affects up to 2.3.0 · reported by PatchstackMedium 5.3
- May 24, 2024Spectra – WordPress Gutenberg Blocks: Stored Cross-Site ScriptingCVE-2024-4366 · affects up to 2.13.0 · reported by WordfenceMedium 6.4
- May 23, 2024Spectra – WordPress Gutenberg Blocks: Stored Cross-Site ScriptingCVE-2024-1815 · affects up to 2.12.8 · reported by WordfenceMedium 6.4
- May 23, 2024Spectra – WordPress Gutenberg Blocks: Stored Cross-Site ScriptingCVE-2024-1814 · affects up to 2.12.8 · reported by WordfenceMedium 6.4
- May 2, 2024Spectra – WordPress Gutenberg Blocks: Path TraversalCVE-2024-3107 · affects up to 2.12.6 · reported by WordfenceMedium 4.3
- Apr 9, 2024Spectra – WordPress Gutenberg Blocks: Stored Cross-Site ScriptingCVE-2023-6486 · affects up to 2.10.3 · reported by WordfenceMedium 6.4
- Mar 28, 2024Spectra: Server-Side Request Forgery (SSRF)CVE-2023-36679 · affects up to 2.6.6 · reported by PatchstackHigh 7.1
- Dec 14, 2023Spectra – WordPress Gutenberg Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-49833 · affects up to 2.7.9 · reported by PatchstackMedium 6.5
- Feb 21, 2023Spectra: Does not sanitize user inputCVE-2020-36656 · fixed in 1.15.0 · reported by WPScanMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.