WordPress plugin · the-plus-addons-for-block-editor
Is Nexter Blocks safe?
Safe on 5.0.9 or newer.
The current version, 5.0.9, is past every affected range on record (13 of 13 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 13
- High or critical
- 1
- Exploited
- none
- Current version
- 5.0.9
- Last updated
- Oct 28, 2026
- Active installs
- 9,000+
Every recorded flaw
- Aug 9, 2026Nexter Blocks: Does not restrict who can save global CSS through one of its REST endpointsCVE-2026-17011 · fixed in 5.0.2 · reported by WPScanLow 3.8
- Aug 6, 2026Nexter Blocks: Does not sanitize uploaded SVG files and allows SVG uploads for any user able to upload files (Author by default)CVE-2025-15678 · fixed in 5.0.2 · reported by WPScanMedium 6.1
- Jul 24, 2026Nexter Blocks – Gutenberg Blocks, Page Builder & AI Website Builder: Directory TraversalCVE-2026-15420 · affects up to 5.0.0 · reported by WordfenceMedium 4.3
- Jul 8, 2026Nexter Blocks – Gutenberg Blocks, Page Builder & AI Website Builder: Stored Cross-Site ScriptingCVE-2026-6740 · affects up to 4.7.4 · reported by WordfenceMedium 6.4
- Apr 8, 2026Nexter Blocks: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2026-39516 · affects up to 4.7.0 · reported by PatchstackMedium 5.3
- Feb 20, 2026Nexter Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-50452 · affects up to 3.3.3 · reported by PatchstackMedium 6.5
- Jan 22, 2026Nexter Blocks: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2026-24377 · affects up to 4.6.3 · reported by PatchstackMedium 4.3
- Aug 19, 2025Nexter Blocks: Stored Cross-Site ScriptingCVE-2025-8567 · affects up to 4.5.4 · reported by WordfenceMedium 6.4
- Aug 14, 2025Nexter Blocks: Missing AuthorizationCVE-2025-54739 · affects up to 4.5.4 · reported by PatchstackMedium 5.3
- Jan 7, 2025Nexter Blocks: Missing AuthorizationCVE-2024-56294 · affects up to 4.0.7 · reported by PatchstackMedium 6.4
- Jan 2, 2025Nexter Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-56246 · affects up to 4.0.4 · reported by PatchstackMedium 6.5
- Jun 9, 2024Nexter Blocks: Missing AuthorizationCVE-2024-33572 · affects up to 3.2.5 · reported by PatchstackMedium 4.3
- Mar 29, 2024Nexter Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-30435 · affects up to 3.2.5 · reported by PatchstackHigh 7.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.