WordPress plugin · swatchly
Is Swatchly safe?
Safe on 1.4.17 or newer.
The current version, 1.4.17, is past every affected range on record (3 of 3 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 3
- High or critical
- 1
- Exploited
- none
- Current version
- 1.4.17
- Last updated
- Oct 8, 2026
- Active installs
- 5,000+
Every recorded flaw
- Aug 20, 2026Unauthenticated Cross Site Scripting (XSS) in Swatchly – WooCommerce Variation Swatches for Products <= 1.4.13 versions.CVE-2026-66605 · affects up to 1.4.13 · reported by PatchstackHigh 7.1
- Apr 10, 2025The Swatchly – WooCommerce Variation Swatches for Products (product attributes: Image swatch, Color swatches, Label swatches) plugin for WordPress is vulnerableCVE-2025-2719 · affects 1.2.8 to 1.4.0 · reported by WordfenceMedium 6.5
- Jul 11, 2023Cross-Site Request Forgery (CSRF) vulnerability in HasThemes Swatchly plugin <= 1.2.0 versions.CVE-2023-23792 · fixed in 1.2.1 · reported by PatchstackMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.