WordPress plugin · subscriptions-for-woocommerce
Is Subscriptions for WooCommerce safe?
Safe on 2.1.0 or newer.
The current version, 2.1.0, is past every affected range on record (9 of 10 records list one; 1 doesn’t, so check it below). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 5
- Exploited
- none
- Current version
- 2.1.0
- Last updated
- Oct 5, 2026
- Active installs
- 10,000+
Every recorded flaw
- Sep 16, 2026Subscriptions for WooCommerce: Does not verify the security token on the request that cancels a subscriptionCVE-2026-87860 · fixed in 2.0.3 · reported by WPScanMedium 4.3
- Sep 16, 2026Subscriptions for WooCommerce: Does not correctly validate the shared secret protecting one of its REST endpointsCVE-2026-87854 · fixed in 2.0.3 · reported by WPScanMedium 5.3
- Aug 7, 2026Subscriptions for WooCommerce: Does not validate the payment amount or bind the PayPal order token to the order being completed on the WooCommerce order-received flow: it captures a client-supplied token and marks the orCVE-2026-15211 · fixed in 2.0.1 · reported by WPScanMedium 5.9
- Aug 7, 2026Subscriptions for WooCommerce: Does not verify the user's capability before installing and activating a Subscriptions for WooCommerce WordPress plugin before 2CVE-2026-15215 · fixed in 2.0.1 · reported by WPScanHigh 8.8
- Aug 7, 2026Subscriptions for WooCommerce: Does not verify that the requester owns the subscription being viewed before rendering its detailsCVE-2026-15214 · fixed in 2.0.1 · reported by WPScanMedium 4.3
- Jul 31, 2026Subscriptions for WooCommerce: Privilege EscalationCVE-2026-15414 · affects up to 2.0.0 · reported by WordfenceHigh 8.8
- Jul 30, 2026Subscriptions for WooCommerce: Missing AuthorizationCVE-2026-15397 · affects up to 2.0.0 · reported by WordfenceHigh 7.2
- Jun 26, 2026Unauthenticated Broken Access Control in Subscriptions for WooCommerce <= 1.9.5 versions.CVE-2026-56061 · reported by PatchstackHigh 7.5
- Mar 25, 2026Subscriptions for WooCommerce: Authentication Bypass by SpoofingCVE-2026-24372 · affects up to 1.8.10 · reported by PatchstackHigh 7.5
- Mar 18, 2026Subscriptions for WooCommerce: Unauthorized modification of dataCVE-2026-1926 · affects up to 1.9.2 · reported by WordfenceMedium 5.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.