WordPress plugin · squirrly-seo
Is GEO Plugin by Squirrly SEO safe?
Safe on 14.2.8 or newer.
The current version, 14.2.8, is past every affected range on record (18 of 18 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 18
- High or critical
- 11
- Exploited
- none
- Current version
- 14.2.8
- Last updated
- Oct 28, 2026
- Active installs
- 30,000+
Every recorded flaw
- Sep 30, 2026Contributor PHP Object Injection in SEO Plugin by Squirrly SEO <= 14.2.5 versions.CVE-2026-94076 · affects up to 14.2.5 · reported by PatchstackHigh 8.8
- Aug 20, 2026Unauthenticated Cross Site Scripting (XSS) in SEO Plugin by Squirrly SEO <= 14.2.2 versions.CVE-2026-66614 · affects up to 14.2.2 · reported by PatchstackHigh 7.1
- Aug 6, 2026Unauthenticated Cross Site Scripting (XSS) in SEO Plugin by Squirrly SEO <= 14.2.0 versions.CVE-2026-66664 · affects up to 14.2.0 · reported by PatchstackHigh 7.1
- Jul 10, 2026SEO Plugin by Squirrly SEO: Arbitrary Post Creation and Stored Cross-Site ScriptingCVE-2026-1667 · affects up to 14.0.0 · reported by WordfenceHigh 7.2
- Jun 16, 2026Unauthenticated Broken Access Control in SEO Plugin by Squirrly SEO <= 12.4.16 versions.CVE-2026-52714 · affects up to 12.4.16 · reported by PatchstackMedium 5.9
- Jun 6, 2026SEO Plugin by Squirrly SEO: Authorization bypassCVE-2026-7624 · affects up to 12.4.16 · reported by WordfenceMedium 4.3
- Feb 19, 2026SEO Plugin by Squirrly SEO: Unauthorized modification of dataCVE-2025-14342 · affects up to 12.4.14 · reported by WordfenceMedium 4.3
- Mar 27, 2025SEO Plugin by Squirrly SEO: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-22783 · affects up to 12.4.03 · reported by PatchstackHigh 8.5
- Mar 7, 2025SEO Plugin by Squirrly SEO: Blind SQL InjectionCVE-2025-1768 · affects up to 12.4.05 · reported by WordfenceMedium 6.5
- Mar 3, 2025SEO Plugin by Squirrly SEO: Missing AuthorizationCVE-2025-24654 · affects up to 12.4.07 · reported by PatchstackHigh 7.1
- Aug 18, 2024SEO Plugin by Squirrly SEO: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2024-43286 · affects up to 12.3.19 · reported by PatchstackHigh 8.5
- Jul 20, 2024SEO Plugin by Squirrly SEO: Stored Cross-Site ScriptingCVE-2024-6497 · affects up to 12.3.19 · reported by Wordfence11% oddsHigh 8.8
- Mar 27, 2024SEO Plugin by Squirrly SEO: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29790 · affects up to 12.3.16 · reported by PatchstackHigh 7.1
- Mar 25, 2024SEO Plugin by Squirrly SEO: Missing AuthorizationCVE-2022-44626 · affects up to 12.1.20 · reported by PatchstackMedium 6.3
- Feb 5, 2024SEO Plugin by Squirrly SEO: Stored Cross-Site ScriptingCVE-2024-0597 · affects up to 12.3.15 · reported by WordfenceMedium 4.4
- May 8, 2023Unauth.CVE-2022-45065 · affects up to 12.1.20 · reported by PatchstackHigh 7.1
- Nov 28, 2022Auth.CVE-2022-38140 · affects up to 12.1.10 · reported by PatchstackHigh 7.6
- Mar 21, 2022SEO Plugin by Squirrly SEO: Does not escape the type parameter before outputting it back in an attribute in an admin pageCVE-2021-25019 · fixed in 11.1.12 · reported by WPScanMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.