WordPress plugin · so-widgets-bundle
Is SiteOrigin Widgets Bundle safe?
Safe on 1.75.0 or newer.
The current version, 1.75.0, is past every affected range on record (13 of 13 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 13
- High or critical
- 2
- Exploited
- none
- Current version
- 1.75.0
- Last updated
- Oct 2, 2026
- Active installs
- 400,000+
Every recorded flaw
- Oct 10, 2026SiteOrigin Widgets Bundle: Directory TraversalCVE-2026-97348 · affects up to 1.74.3 · reported by WordfenceMedium 6.5
- Oct 2, 2026SiteOrigin Widgets Bundle: Local File InclusionCVE-2026-92174 · affects up to 1.73.2 · reported by WordfenceHigh 7.5
- Feb 18, 2026SiteOrigin Widgets Bundle: Unauthorized arbitrary shortcode executionCVE-2026-2127 · affects up to 1.70.4 · reported by WordfenceMedium 5.4
- Jun 24, 2025SiteOrigin Widgets Bundle: Stored Cross-Site ScriptingCVE-2025-5585 · affects up to 1.68.4 · reported by WordfenceMedium 6.4
- Dec 13, 2024SiteOrigin Widgets Bundle: Missing AuthorizationCVE-2024-54268 · affects up to 1.64.0 · reported by PatchstackMedium 4.3
- Jul 30, 2024SiteOrigin Widgets Bundle: Stored Cross-Site ScriptingCVE-2024-5901 · affects up to 1.62.2 · reported by WordfenceMedium 6.4
- Jun 10, 2024SiteOrigin Widgets Bundle: Stored Cross-Site ScriptingCVE-2024-5090 · affects up to 1.61.1 · reported by WordfenceMedium 6.4
- May 22, 2024SiteOrigin Widgets Bundle: Stored Cross-Site ScriptingCVE-2024-4362 · affects up to 1.60.0 · reported by WordfenceMedium 6.4
- Mar 13, 2024SiteOrigin Widgets Bundle: Stored Cross-Site ScriptingCVE-2024-1723 · affects up to 1.58.7 · reported by WordfenceMedium 6.4
- Feb 28, 2024SiteOrigin Widgets Bundle: Stored Cross-Site ScriptingCVE-2024-1070 · affects up to 1.58.2 · reported by WordfenceMedium 6.4
- Feb 28, 2024SiteOrigin Widgets Bundle: Stored Cross-Site ScriptingCVE-2024-1058 · affects up to 1.58.3 · reported by WordfenceMedium 6.4
- Feb 5, 2024SiteOrigin Widgets Bundle: Stored Cross-Site ScriptingCVE-2024-0961 · affects up to 1.58.1 · reported by WordfenceMedium 6.4
- Dec 18, 2023SiteOrigin Widgets Bundle: Does not validate user input before using it to generate paths passed to include function/sCVE-2023-6295 · fixed in 1.51.0 · reported by WPScan1.0% oddsHigh 7.2
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.