WordPress plugin · slider-wd
Is Slider by 10Web safe?
3 flaws affect the current version.
The newest release on wordpress.org, 1.2.63, is inside the affected range of 3 records, so there may be no fix yet. Check the changelog; if it doesn’t mention the fix, deactivate it until it does.
- Flaws on record
- 11
- High or critical
- 6
- Exploited
- none
- Current version
- 1.2.63
- Last updated
- Oct 6, 2026
- Active installs
- 10,000+
Every recorded flaw
- Oct 10, 2026Unauthenticated Cross Site Scripting (XSS) in Slider by 10Web <= 1.2.63 versions.CVE-2026-42711 · affects up to 1.2.63 · reported by PatchstackHigh 7.1
- Oct 10, 2026Slider by 10Web: Deserialization of Untrusted DataCVE-2026-105885 · affects up to 1.2.62 · reported by PatchstackHigh 8.8
- Oct 7, 2026Slider by 10Web: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-42710 · affects up to 1.2.63 · reported by PatchstackHigh 7.6
- Aug 18, 2026Slider by 10Web: Cross-Site Request Forgery (CSRF)CVE-2026-66635 · affects up to 1.2.63 · reported by PatchstackHigh 7.4
- Mar 25, 2025Slider by 10Web: Does not sanitise and escape some of its settingsCVE-2024-10566 · fixed in 1.2.62 · reported by WPScanMedium 6.1
- Mar 25, 2025Slider by 10Web: Does not sanitise and escape some of its settingsCVE-2024-10565 · fixed in 1.2.62 · reported by WPScanMedium 6.1
- Sep 30, 2024Slider by 10Web: Does not sanitise and escape some of its settingsCVE-2024-8283 · fixed in 1.2.59 · reported by WPScanMedium 4.8
- Aug 8, 2024Slider by 10Web – Responsive Image Slider: Time-based SQL InjectionCVE-2024-7150 · affects up to 1.2.57 · reported by WordfenceHigh 8.8
- Jul 31, 2024Slider by 10Web: Does not sanitise and escape its Slider TitleCVE-2024-6408 · fixed in 1.2.57 · reported by WPScanMedium 5.4
- Jul 11, 2024Slider by 10Web: Does not sanitise and escape some of its Slide optionsCVE-2024-6026 · fixed in 1.2.56 · reported by WPScanMedium 5.4
- Apr 18, 2024Slider by 10Web: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-32578 · affects up to 1.2.54 · reported by PatchstackHigh 7.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.