WordPress plugin · simple-job-board
Is Simple Job Board safe?
Safe on 2.14.5 or newer.
The current version, 2.14.5, is past every affected range on record (12 of 12 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 12
- High or critical
- 4
- Exploited
- none
- Current version
- 2.14.5
- Last updated
- Sep 8, 2026
- Active installs
- 10,000+
Every recorded flaw
- Oct 22, 2025Simple Job Board: Insertion of Sensitive Information Into Sent DataCVE-2025-59579 · affects up to 2.13.7 · reported by PatchstackHigh 7.5
- May 15, 2025Simple Job Board: Does not prevent uploaded files from being listedCVE-2024-7762 · fixed in 2.12.6 · reported by WPScanLow 3.7
- Jan 2, 2025Simple Job Board: Missing AuthorizationCVE-2023-47188 · affects up to 2.10.5 · reported by PatchstackMedium 5.3
- Aug 24, 2024Simple Job Board: PHP Object InjectionCVE-2024-7351 · affects up to 2.12.3 · reported by WordfenceHigh 7.2
- Apr 9, 2024Simple Job Board: PHP Object InjectionCVE-2024-1813 · affects up to 2.11.0 · reported by Wordfence1.2% oddsCritical 9.8
- Feb 21, 2024Simple Job Board: Unauthorized access of data|CVE-2024-0593 · affects up to 2.10.8 · reported by WordfenceMedium 5.3
- Jan 5, 2024Simple Job Board: Cross-Site Request Forgery (CSRF)CVE-2023-52122 · affects up to 2.10.6 · reported by PatchstackMedium 4.3
- Nov 10, 2023Cross-Site Request Forgery (CSRF) vulnerability in PressTigers Simple Job Board plugin <= 2.10.3 versions.CVE-2023-29440 · affects up to 2.10.3 · reported by PatchstackMedium 4.3
- Aug 22, 2022Simple Job Board: Is susceptible to Directory ListingCVE-2022-2558 · fixed in 2.10.0 · reported by WPScanMedium 5.3
- Oct 21, 2021Simple Job Board: Stored Cross-Site ScriptingCVE-2021-39328 · affects up to 2.9.4 · reported by WordfenceMedium 5.5
- Jan 15, 2021Directory traversal vulnerability in class-simple_job_board_resume_download_handler.php in the Simple Board Job plugin 2.9.3 and earlier for WordPress allows reCVE-2020-35749 · affects up to 2.9.3 · reported by MITRE30% oddsHigh 7.7
- Aug 13, 2019The simple-job-board plugin before 2.4.4 for WordPress has reflected XSS via keyword search.CVE-2017-18498 · fixed in 2.4.4 · reported by MITREMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.