WordPress plugin · simple-blog-card
Is Simple Blog Card safe?
Safe on 2.38 or newer.
The current version, 2.38, is past every affected range on record (3 of 3 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 3
- High or critical
- 0
- Exploited
- none
- Current version
- 2.38
- Last updated
- Aug 16, 2026
- Active installs
- 3,000+
Every recorded flaw
- Mar 13, 2026Simple Blog Card: Server-Side Request Forgery (SSRF)CVE-2026-32357 · affects up to 2.37 · reported by PatchstackMedium 6.4
- Aug 30, 2023Simple Blog Card: Does not ensure that posts to be displayed via a shortcode are publicCVE-2023-4036 · fixed in 1.32 · reported by WPScanMedium 4.3
- Aug 30, 2023Simple Blog Card: Does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embedCVE-2023-4035 · fixed in 1.31 · reported by WPScanMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.