WordPress plugin · sensei-lms
Is Sensei LMS safe?
Safe on 4.26.4 or newer.
The current version, 4.26.4, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 0
- Exploited
- none
- Current version
- 4.26.4
- Last updated
- Sep 29, 2026
- Active installs
- 9,000+
Every recorded flaw
- Oct 19, 2026Sensei LMS: Contains a broken access control vulnerability in the legacy save_new_message handler hooked on the init actionCVE-2026-112329 · fixed in 4.26.4 · reported by VulnCheckMedium 5.3
- Oct 19, 2026Sensei LMS: Contains a broken access control vulnerability in the add_new_module_term AJAX handler that allows authenticated Teacher-role attackers to assign module taxonomy terms to arbitrary courses by supplying a crafCVE-2026-112328 · fixed in 4.26.4 · reported by VulnCheckMedium 5.3
- May 15, 2025The Sensei LMS WordPress plugin before 4.20.0 disclose all users of the blog including their email address to teachers on the students pageCVE-2024-8009 · fixed in 4.20.0 · reported by WPScanMedium 4.3
- Mar 27, 2025Sensei LMS: Missing AuthorizationCVE-2025-22740 · affects up to 4.24.4 · reported by PatchstackMedium 5.3
- Feb 4, 2025Sensei LMS: Does not properly protect some its REST API routesCVE-2025-0466 · fixed in 4.24.4 · reported by WPScanMedium 5.3
- Sep 4, 2024Sensei LMS: Does not properly protect some its REST API routesCVE-2024-7786 · fixed in 4.24.2 · reported by WPScan1.7% oddsMedium 5.3
- Aug 18, 2024Sensei LMS: Missing AuthorizationCVE-2024-35686 · affects up to 4.23.1 · reported by PatchstackMedium 5.3
- Feb 12, 2024Sensei LMS – Online Courses, Quizzes, & Learning: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-50875 · affects up to 4.17.0 · reported by PatchstackMedium 6.5
- Aug 29, 2022Sensei LMS: Does not ensure that the sender of a private message is either the teacher or the original senderCVE-2022-2080 · fixed in 4.5.2 · reported by WPScanMedium 4.3
- Aug 29, 2022Sensei LMS: Does not have proper permissions set in one of its REST endpointCVE-2022-2034 · fixed in 4.5.0 · reported by WPScan2.7% oddsMedium 5.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.