WordPress plugin · sendpress
Is SendPress Newsletters safe?
Closed. Replace it.
wordpress.org closed it on Sep 28, 2026, so it gets no more security fixes, and 11 flaws are on record. If your site runs it, move to a maintained alternative.
- Flaws on record
- 11
- High or critical
- 3
- Exploited
- none
Every recorded flaw
- Oct 9, 2026SendPress Newsletters: Protects a logging endpoint with a hardcoded token that is the same on every site rather than a per-site secretCVE-2026-92990 · affects up to 1.26.1.20 · reported by WPScanMedium 5.3
- Oct 9, 2026SendPress Newsletters: Does not check the user's capability on several newsletter-management actionsCVE-2026-92989 · affects up to 1.26.1.20 · reported by WPScanMedium 4.3
- Oct 6, 2026SendPress Newsletters: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-39795 · affects up to 1.26.1.20 · reported by PatchstackCritical 9.3
- Jun 13, 2024SendPress Newsletters: Missing AuthorizationCVE-2023-35040 · affects up to 1.23.11.6 · reported by PatchstackMedium 5.3
- Apr 8, 2024SendPress Newsletters: Does not sanitise and escape some of its settingsCVE-2024-1589 · affects up to 1.23.11.6 · reported by WPScanMedium 6.1
- Apr 8, 2024SendPress Newsletters: Does not sanitise and escape some of its settingsCVE-2024-1588 · affects up to 1.23.11.6 · reported by WPScanMedium 6.8
- Nov 14, 2023Unauth.CVE-2023-47517 · affects up to 1.23.11.6 · reported by PatchstackHigh 7.1
- Nov 7, 2023SendPress Newsletters: Stored Cross-Site ScriptingCVE-2023-5660 · affects up to 1.22.3.31 · reported by WordfenceMedium 6.4
- Oct 10, 2023Cross-Site Request Forgery (CSRF) vulnerability in SendPress Newsletters plugin <= 1.22.3.31 versions.CVE-2023-41730 · affects up to 1.22.3.31 · reported by PatchstackMedium 4.3
- Oct 2, 2023Auth.CVE-2023-41729 · affects up to 1.22.3.31 · reported by PatchstackMedium 5.9
- Sep 26, 2019The sendpress plugin before 1.2 for WordPress has SQL Injection via the wp-admin/admin.php?page=sp-queue listid parameter.CVE-2015-9448 · fixed in 1.2 · reported by MITRE1.9% oddsHigh 8.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.