WordPress plugin · rife-elementor-extensions
Is Rife Extensions & Templates for Elementor safe?
Safe on 1.2.8 or newer.
The current version, 1.2.8, is past every affected range on record (4 of 4 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 4
- High or critical
- 0
- Exploited
- none
- Current version
- 1.2.8
- Last updated
- Sep 29, 2025
- Active installs
- 20,000+
Every recorded flaw
- Feb 22, 2025Rife Elementor Extensions & Templates: Stored Cross-Site ScriptingCVE-2024-13564 · affects up to 1.2.5 · reported by WordfenceMedium 6.4
- Dec 9, 2024Rife Elementor Extensions & Templates: Missing AuthorizationCVE-2023-27454 · affects up to 1.1.10 · reported by PatchstackMedium 5.4
- Jul 2, 2024Rife Elementor Extensions & Templates: Stored Cross-Site ScriptingCVE-2024-5504 · affects up to 1.2.1 · reported by WordfenceMedium 6.4
- May 5, 2021Rife Elementor Extensions & Templates: Has a widget that is vulnerable to stored Cross-Site Scripting(XSS) by lower-privileged users suchCVE-2021-24265 · fixed in 1.1.6 · reported by WPScanMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.