WordPress plugin · restrict-content
Is Membership Plugin safe?
Safe on 4.0.5 or newer.
The current version, 4.0.5, is past every affected range on record (11 of 11 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 11
- High or critical
- 4
- Exploited
- none
- Current version
- 4.0.5
- Last updated
- Oct 14, 2026
- Active installs
- 8,000+
Every recorded flaw
- Aug 5, 2026The Membership Plugin – Kadence Memberships plugin for WordPress (formerly Restrict Content) is vulnerable to password reset link poisoning leading to account tCVE-2026-9273 · affects up to 4.0.0 · reported by WordfenceCritical 9.3
- Mar 25, 2026Restrict Content: Missing AuthorizationCVE-2026-32546 · affects up to 3.2.22 · reported by PatchstackHigh 7.5
- Mar 20, 2026Membership Plugin – Restrict Content: Unvalidated RedirectCVE-2026-4136 · affects up to 3.2.24 · reported by WordfenceMedium 4.3
- Mar 5, 2026Membership Plugin – Restrict Content: Privilege EscalationCVE-2026-1321 · affects up to 3.2.20 · reported by WordfenceHigh 8.1
- Feb 18, 2026Membership Plugin – Restrict Content: Stored Cross-Site ScriptingCVE-2026-1304 · affects up to 3.2.18 · reported by WordfenceMedium 4.4
- Jan 16, 2026Membership Plugin – Restrict Content: Missing AuthenticationCVE-2025-14844 · affects up to 3.2.16 · reported by WordfenceHigh 8.2
- Dec 23, 2025Membership Plugin – Restrict Content: Stored Cross-Site ScriptingCVE-2025-14000 · affects up to 3.2.15 · reported by WordfenceMedium 6.4
- Jan 26, 2025Membership Plugin – Restrict Content: Sensitive Information ExposureCVE-2024-11090 · affects up to 3.2.13 · reported by WordfenceMedium 5.3
- Apr 15, 2024Restrict Content: Missing AuthorizationCVE-2024-31432 · affects up to 3.2.8 · reported by PatchstackMedium 5.3
- Nov 22, 2023Exposure of Sensitive Information to an Unauthorized Actor vulnerability in StellarWP Membership Plugin – Restrict Content plugin <= 3.2.7 versions.CVE-2023-47668 · affects up to 3.2.7 · reported by Patchstack1.0% oddsMedium 5.3
- Jul 17, 2023Membership: Does not sanitise and escape a parameter before outputting it back in the pageCVE-2023-3182 · fixed in 3.2.3 · reported by WPScanMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.