WordPress plugin · responsive-block-editor-addons
Is Responsive Blocks safe?
Safe on 2.3.0 or newer.
The current version, 2.3.0, is past every affected range on record (11 of 11 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 11
- High or critical
- 0
- Exploited
- none
- Current version
- 2.3.0
- Last updated
- Oct 6, 2026
- Active installs
- 3,000+
Every recorded flaw
- Oct 14, 2026Responsive Blocks: Does not sanitise or escape some of the values submitted with its Form block before adding them to the HTML notification email sent to the site ownerCVE-2026-97315 · fixed in 2.3.0 · reported by WPScanMedium 5.4
- Apr 21, 2026Responsive Blocks – Page Builder for Blocks & Patterns: Unauthorized accessCVE-2026-6703 · affects up to 2.2.1 · reported by WordfenceMedium 4.3
- Apr 20, 2026Responsive Blocks – Page Builder for Blocks & Patterns: Unauthenticated Open Email RelayCVE-2026-6675 · affects up to 2.2.0 · reported by WordfenceMedium 5.3
- Mar 13, 2026Responsive Blocks: Missing AuthorizationCVE-2026-32543 · affects up to 2.2.0 · reported by PatchstackMedium 5.3
- Jun 27, 2025Responsive Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-53202 · affects up to 2.0.6 · reported by PatchstackMedium 6.5
- Jun 17, 2025Responsive Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-49881 · affects up to 2.0.5 · reported by PatchstackMedium 6.5
- Apr 16, 2025Responsive Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-39578 · affects up to 2.0.2 · reported by PatchstackMedium 6.5
- Feb 4, 2025Responsive Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-22697 · affects up to 1.9.9 · reported by PatchstackMedium 6.5
- Jan 30, 2025Responsive Blocks – WordPress Gutenberg Blocks: Stored Cross-Site ScriptingCVE-2024-13732 · affects up to 1.9.9 · reported by WordfenceMedium 6.4
- Dec 24, 2024Responsive Blocks – WordPress Gutenberg Blocks: Stored Cross-Site ScriptingCVE-2024-12268 · affects up to 1.9.7 · reported by WordfenceMedium 6.4
- Aug 18, 2024Responsive Blocks – WordPress Gutenberg Blocks: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-43335 · affects up to 1.8.8 · reported by PatchstackMedium 6.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.