WordPress plugin · relevanssi
Is Relevanssi safe?
Safe on 4.28.6 or newer.
The current version, 4.28.6, is past every affected range on record (12 of 13 records list one; 1 doesn’t, so check it below). Keep it updated and you’re clear of them.
- Flaws on record
- 13
- High or critical
- 3
- Exploited
- none
- Current version
- 4.28.6
- Last updated
- Oct 27, 2026
- Active installs
- 100,000+
Every recorded flaw
- Oct 24, 2026Relevanssi: Deserialization of Untrusted DataCVE-2026-114704 · affects up to 4.28.4 · reported by PatchstackHigh 7.2
- Oct 2, 2026Relevanssi – A Better Search: Stored Cross-Site ScriptingCVE-2026-97641 · affects up to 4.28.3 · reported by WordfenceHigh 7.2
- Sep 11, 2026Relevanssi – A Better Search: Reflected Cross-Site ScriptingCVE-2026-19985 · affects up to 4.28.1 · reported by WordfenceMedium 6.1
- Aug 5, 2026The plugin provides an Admin Search page that allows users with the `edit_posts` capability to run Relevanssi searches from the WordPress dashboard.CVE-2026-15941 · reported by WordfenceMedium 6.5
- May 31, 2025Relevanssi – A Better Search: Stored Cross-Site ScriptingCVE-2025-5016 · affects up to 4.24.5 · reported by WordfenceMedium 4.7
- May 13, 2025Relevanssi – A Better Search: Time-based SQL InjectionCVE-2025-4396 · affects up to 4.24.4 · reported by Wordfence2.7% oddsHigh 7.5
- May 6, 2025Relevanssi – A Better Search: Stored Cross-Site ScriptingCVE-2025-4054 · affects up to 4.24.3 · reported by WordfenceMedium 6.1
- Aug 15, 2024Relevanssi – A Better Search: Information ExposureCVE-2024-7630 · affects up to 4.22.2 · reported by WordfenceMedium 5.3
- Apr 9, 2024Relevanssi – A Better Search: CSV InjectionCVE-2024-3214 · affects up to 4.22.1 · reported by WordfenceMedium 5.8
- Apr 9, 2024Relevanssi – A Better Search: Unauthorized modification of dataCVE-2024-3213 · affects up to 4.22.1 · reported by WordfenceMedium 5.3
- Mar 13, 2024Relevanssi – A Better Search: Unauthorized access of dataCVE-2024-1380 · affects up to 4.22.0 · reported by Wordfence50% oddsMedium 5.3
- Jan 29, 2024The Relevanssi WordPress plugin before 4.22.0, Relevanssi Premium WordPress plugin before 2.25.0 allows any unauthenticated user to read draft and private postsCVE-2023-7199 · fixed in 4.22.0 · reported by WPScanMedium 5.3
- Jan 2, 2015Cross-site scripting (XSS) vulnerability in the Relevanssi plugin before 3.3.8 for WordPress allows remote attackers to inject arbitrary web script or HTML via CVE-2014-9443 · fixed in 3.3.8 · reported by MITRE1.6% oddsMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.