WordPress plugin · really-simple-ssl
Is Really Simple Security safe?
Safe on 9.8.4 or newer.
The current version, 9.8.4, is past every affected range on record (13 of 13 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 13
- High or critical
- 5
- Exploited
- none
- Current version
- 9.8.4
- Last updated
- Oct 26, 2026
- Active installs
- 3,000,000+
Every recorded flaw
- Sep 18, 2026Really Simple Security: Does not validate a client-supplied address value before using itCVE-2026-88798 · fixed in 9.8.3 · reported by WPScanMedium 5.3
- Sep 14, 2026Really Simple Security: Missing authorization checkCVE-2026-82519 · fixed in 9.8.2 · reported by VulnCheckLow 2.3
- Sep 13, 2026Really Simple Security: Does not prevent an unauthenticated request from resetting an account's completed email two-factor enrolmentCVE-2026-89080 · fixed in 9.8.1 · reported by WPScanHigh 7.5
- Sep 3, 2026Unauthenticated Broken Authentication in Really Simple SSL <= 9.8.0 versions.CVE-2026-84777 · affects up to 9.8.0 · reported by PatchstackHigh 7.4
- Sep 2, 2026Unauthenticated Denial of Service Attack in Really Simple SSL <= 9.8.0 versions.CVE-2026-84775 · affects up to 9.8.0 · reported by PatchstackMedium 5.3
- Aug 30, 2026Really Simple Security: Does not check that the user is allowed to install Really Simple Security WordPress plugin before 9CVE-2026-81766 · fixed in 9.8.0 · reported by WPScanMedium 6.6
- Jun 15, 2026Unauthenticated Broken Authentication in Really Simple SSL <= 9.5.10 versions.CVE-2026-48970 · affects up to 9.5.10 · reported by PatchstackHigh 8.1
- Jun 15, 2026Subscriber Broken Access Control in Really Simple SSL <= 9.5.9 versions.CVE-2026-48969 · affects up to 9.5.9 · reported by PatchstackMedium 6.5
- Jun 2, 2026Really Simple Security: Does not enforce the second-factor challenge in two of its two-factor authentication REST endpointsCVE-2026-8293 · fixed in 9.5.10.1 · reported by WPScanHigh 7.5
- Mar 13, 2026Really Simple SSL: Missing AuthorizationCVE-2026-32461 · affects up to 9.5.7 · reported by PatchstackMedium 4.3
- Jan 24, 2025Really Simple SSL: Cross-Site Request Forgery (CSRF)CVE-2025-24623 · affects up to 9.1.4 · reported by PatchstackMedium 4.3
- Nov 14, 2024The Really Simple Security (Free, Pro, and Pro Multisite) plugins for WordPress are vulnerable to authentication bypass in versions 9.0.0 to 9.1.1.1.CVE-2024-10924 · affects 9.0.0 to 9.1.1.1 · reported by Wordfence82% oddsCritical 9.8
- Apr 18, 2024Really Simple SSL: Server-Side Request Forgery (SSRF)CVE-2024-31229 · affects up to 7.2.3 · reported by PatchstackMedium 5.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.