WordPress plugin · qi-blocks
Is Qi Blocks safe?
Safe on 1.5.4 or newer.
The current version, 1.5.4, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 1
- Exploited
- none
- Current version
- 1.5.4
- Last updated
- Oct 22, 2026
- Active installs
- 60,000+
Every recorded flaw
- Jul 1, 2026Qi Blocks: Insecure Direct Object ReferenceCVE-2026-10096 · affects up to 1.4.9 · reported by WordfenceMedium 4.3
- Nov 14, 2025Qi Blocks: Unauthorized accessCVE-2025-12182 · affects up to 1.4.3 · reported by WordfenceMedium 4.3
- Nov 13, 2025Qi Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-64383 · affects up to 1.4.3 · reported by PatchstackMedium 6.5
- Nov 1, 2025Qi Blocks: Missing AuthorizationCVE-2025-12180 · affects up to 1.4.3 · reported by WordfenceMedium 4.3
- May 19, 2025Qi Blocks: Does not validate and escape some of its block options before outputting them back in a page/post where the block is embedCVE-2025-1627 · fixed in 1.4 · reported by WPScanMedium 5.4
- May 19, 2025Qi Blocks: Does not validate and escape some of its Countdown block options before outputting them back in a page/post where the block is embedCVE-2025-1626 · fixed in 1.4 · reported by WPScanMedium 5.4
- May 19, 2025Qi Blocks: Does not validate and escape some of its Counter block options before outputting them back in a page/post where the block is embedCVE-2025-1625 · fixed in 1.4 · reported by WPScanMedium 5.4
- Oct 23, 2024Qi Blocks: Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')CVE-2024-49690 · affects up to 1.3.2 · reported by PatchstackHigh 7.5
- Jul 20, 2024Qi Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-38712 · affects up to 1.3 · reported by PatchstackMedium 6.5
- Jun 6, 2024Qi Blocks: Stored Cross-Site ScriptingCVE-2024-5221 · affects up to 1.2.9 · reported by WordfenceMedium 6.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.