WordPress plugin · pretty-link
Is PrettyLinks safe?
Safe on 4.0.18 or newer.
The current version, 4.0.18, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 3
- Exploited
- none
- Current version
- 4.0.18
- Last updated
- Oct 21, 2026
- Active installs
- 200,000+
Every recorded flaw
- Aug 5, 2026PrettyLinks – Affiliate Links, Link Branding, Link Tracking, Marketing and Stripe Payments: SQL InjectionCVE-2026-5062 · affects up to 3.6.20 · reported by WordfenceMedium 4.9
- May 19, 2025Shortlinks by Pretty Links: Missing AuthorizationCVE-2025-48247 · affects up to 3.6.15 · reported by PatchstackMedium 4.3
- Mar 27, 2024Shortlinks by Pretty Links: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29770 · affects up to 3.6.2 · reported by PatchstackHigh 7.1
- Mar 23, 2024Pretty Links – Affiliate Links, Link Branding, Link Tracking & Marketing: Cross-Site Request ForgeryCVE-2024-2326 · affects up to 3.6.3 · reported by WordfenceMedium 4.3
- Jun 6, 2023Pretty Links: Stored Cross-Site ScriptingCVE-2019-25147 · affects up to 2.1.9 · reported by WordfenceHigh 7.2
- May 25, 2023Cross-Site Request Forgery (CSRF) vulnerability in Pretty Links plugin <= 3.4.0 versions.CVE-2022-47149 · affects up to 1.4 · reported by PatchstackMedium 4.3
- Oct 10, 2019The pretty-link plugin before 1.6.8 for WordPress has PrliLinksController::list_links SQL injection via the group parameter.CVE-2015-9457 · fixed in 1.6.8 · reported by MITRE1.9% oddsHigh 7.2
- Mar 12, 2014Cross-site scripting (XSS) vulnerability in open-flash-chart.swf in Open Flash Chart (aka Open-Flash Chart), as used in the Pretty Link Lite plugin before 1.6.3CVE-2013-1636 · affects up to 4.2.9 · fixed in 1.6.3 · reported by MITRE6.3% oddsMedium 4.3
- Sep 23, 2012Cross-site scripting (XSS) vulnerability in pretty-bar.php in Pretty Link Lite plugin before 1.5.6 for WordPress allows remote attackers to inject arbitrary webCVE-2011-5192 · fixed in 1.5.6 · reported by MITRE2.1% oddsMedium 4.3
- Sep 23, 2012Cross-site scripting (XSS) vulnerability in pretty-bar.php in Pretty Link Lite plugin before 1.5.4 for WordPress allows remote attackers to inject arbitrary webCVE-2011-5191 · fixed in 1.5.4 · reported by MITRE1.7% oddsMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.