WordPress plugin · post-grid
Is Post Grid safe?
Safe on 2.3.24 or newer.
The current version, 2.3.24, is past every affected range on record (23 of 24 records list one; 1 doesn’t, so check it below). Keep it updated and you’re clear of them.
- Flaws on record
- 24
- High or critical
- 8
- Exploited
- none
- Current version
- 2.3.24
- Last updated
- Jul 19, 2026
- Active installs
- 30,000+
Every recorded flaw
- Sep 5, 2026Post Grid and Gutenberg Blocks – ComboBlocks: Unauthenticated Hook InjectionCVE-2024-11080 · affects 2.2.32 to 2.3.1 · reported by WordfenceCritical 9.8
- Dec 24, 2025Post Grid and Gutenberg Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-68605 · affects up to 2.3.23 · reported by PatchstackMedium 6.5
- Dec 18, 2025Post Grid and Gutenberg Blocks: Missing AuthorizationCVE-2025-66058 · affects up to 2.3.17 · reported by PatchstackMedium 6.5
- Dec 18, 2025Post Grid and Gutenberg Blocks: Authorization Bypass Through User-Controlled KeyCVE-2025-63043 · affects up to 2.3.23 · reported by PatchstackMedium 5.3
- Oct 26, 2025Post Grid and Gutenberg Blocks: Missing AuthorizationCVE-2025-62924 · affects up to 2.3.17 · reported by PatchstackMedium 6.5
- Aug 20, 2025Post Grid and Gutenberg Blocks: Deserialization of Untrusted DataCVE-2025-54007 · affects up to 2.3.11 · reported by PatchstackHigh 8.8
- Feb 28, 2025Post Grid and Gutenberg Blocks – ComboBlocks: Sensitive Information ExposureCVE-2024-13796 · affects up to 2.3.6 · reported by WordfenceMedium 5.3
- Feb 22, 2025Post Grid and Gutenberg Blocks – ComboBlocks: Unauthorized order creationCVE-2024-13798 · affects up to 2.3.5 · reported by WordfenceMedium 5.3
- Jan 15, 2025Post Grid and Gutenberg Blocks: Privilege escalationCVE-2024-9636 · affects 2.2.85 to 2.3.3 · reported by WordfenceCritical 9.8
- Oct 28, 2024Post Grid and Gutenberg Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-50432 · affects up to 2.2.93 · reported by PatchstackMedium 6.5
- Oct 6, 2024Post Grid and Gutenberg Blocks: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-47340 · affects up to 2.2.89 · reported by PatchstackMedium 6.5
- Sep 11, 2024Post Grid and Gutenberg Blocks: Privilege escalationCVE-2024-8253 · reported by Wordfence9.4% oddsHigh 8.8
- Aug 14, 2024Gutenberg Blocks, Page Builder – ComboBlocks: Stored Cross-Site ScriptingCVE-2024-7588 · affects up to 2.2.87 · reported by WordfenceMedium 6.4
- Aug 12, 2024ComboBlocks: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-43155 · affects up to 2.2.86 · reported by PatchstackMedium 6.5
- Aug 1, 2024Gutenberg Blocks, Page Builder – ComboBlocks: Stored Cross-Site ScriptingCVE-2024-6346 · affects up to 2.2.85 · reported by WordfenceMedium 6.4
- Jun 7, 2024Post Grid, Form Maker, Popup Maker, WooCommerce Blocks, Post Blocks, Post Carousel – Combo Blocks: Stored Cross-Site ScriptingCVE-2024-4042 · affects up to 2.2.80 · reported by WordfenceMedium 6.4
- Jun 7, 2024Post Grid, Form Maker, Popup Maker, WooCommerce Blocks, Post Blocks, Post Carousel – Combo Blocks: Stored Cross-Site ScriptingCVE-2024-1988 · affects up to 2.2.80 · reported by WordfenceMedium 6.4
- May 20, 2024Post Grid, Form Maker, Popup Maker, WooCommerce Blocks, Post Blocks, Post Carousel – Combo Blocks: Stored Cross-Site ScriptingCVE-2024-3155 · affects up to 2.2.80 · reported by WordfenceMedium 6.4
- Apr 24, 2024Post Grid: Exposure of Sensitive Information to an Unauthorized ActorCVE-2024-32816 · affects up to 2.2.78 · reported by PatchstackHigh 7.5
- Apr 11, 2024Post Grid, Form Maker, Popup Maker, WooCommerce Blocks, Post Blocks, Post Carousel: Does not have proper authorizationCVE-2024-0881 · fixed in 2.2.76 · reported by WPScan17% oddsMedium 5.4
- Mar 29, 2024Post Grid: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-30441 · affects up to 2.2.74 · reported by PatchstackHigh 7.1
- Mar 12, 2024Post Grid Combo – 36+ Gutenberg Blocks: Sensitive Information ExposureCVE-2023-7072 · affects up to 2.2.68 · reported by WordfenceHigh 7.5
- Jan 11, 2024Post Grid Combo – 36+ Gutenberg Blocks: Stored Cross-Site ScriptingCVE-2023-6645 · affects up to 2.2.64 · reported by WordfenceMedium 6.4
- Nov 30, 2023Post Grid Combo – 36+ Gutenberg Blocks: Exposure of Sensitive Information to an Unauthorized ActorCVE-2023-40211 · affects up to 2.2.50 · reported by Patchstack2.2% oddsHigh 7.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.