WordPress plugin · post-connector
Is Post Connector safe?
A flaw affects the current version.
The newest release on wordpress.org, 1.0.11, is inside the affected range of CVE-2025-52741, so there may be no fix yet. Check the changelog; if it doesn’t mention the fix, deactivate it until it does.
- Flaws on record
- 3
- High or critical
- 1
- Exploited
- none
- Current version
- 1.0.11
- Last updated
- Sep 21, 2023
- Active installs
- 80+
Every recorded flaw
- Oct 22, 2025Post Connector: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-52741 · affects up to 1.0.11 · reported by PatchstackHigh 7.1
- Aug 8, 2023Auth.CVE-2023-28931 · affects up to 1.0.9 · reported by PatchstackMedium 5.9
- Aug 28, 2019The Post Connector plugin before 1.0.4 for WordPress has XSS via add_query_arg() and remove_query_arg().CVE-2015-9362 · fixed in 1.0.4 · reported by MITREMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.