WordPress plugin · pixelyoursite
Is PixelYourSite safe?
Safe on 11.4.4 or newer.
The current version, 11.4.4, is past every affected range on record (13 of 14 records list one; 1 doesn’t, so check it below). Keep it updated and you’re clear of them.
- Flaws on record
- 14
- High or critical
- 2
- Exploited
- none
- Current version
- 11.4.4
- Last updated
- Oct 21, 2026
- Active installs
- 400,000+
Every recorded flaw
- Sep 23, 2026Subscriber Cross Site Scripting (XSS) in PixelYourSite – Your smart PIXEL (TAG) Manager <= 11.4.1 versions.CVE-2026-95530 · affects up to 11.4.1 · reported by PatchstackMedium 6.5
- Aug 1, 2026PixelYourSite – Your smart PIXEL (TAG) & API Manager: Sensitive Information ExposureCVE-2026-18059 · affects up to 11.2.1 · reported by WordfenceMedium 5.3
- Feb 20, 2026PixelYourSite – Your smart PIXEL (TAG) Manager: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2026-27072 · affects up to 11.2.0.1 · reported by PatchstackHigh 7.1
- Feb 13, 2026PixelYourSite – Your smart PIXEL (TAG) & API Manager: Stored Cross-Site ScriptingCVE-2026-1841 · affects up to 11.2.0 · reported by WordfenceHigh 7.2
- Dec 29, 2025PixelYourSite: Sensitive Information ExposureCVE-2025-14280 · affects up to 11.1.5 · reported by WordfenceMedium 5.3
- Oct 24, 2025PixelYourSite: Does not validate some URL parameters before using them to generate paths passed to function/sCVE-2025-10723 · fixed in 11.1.2 · reported by WPScanLow 2.7
- Oct 22, 2025PixelYourSite – Your smart PIXEL (TAG) & API Manager: Cross-Site Request ForgeryCVE-2025-10588 · affects up to 11.1.2 · reported by WordfenceMedium 4.3
- Feb 28, 2025PixelYourSite - Your smart PIXEL (TAG) and API Manager 10.1.1.1 was found to be vulnerable.CVE-2025-0769 · reported by help@fluidattacks.comMedium 6.3
- Jan 7, 2025PixelYourSite – Your smart PIXEL (TAG) Manager: Cross-Site Request Forgery (CSRF)CVE-2025-22300 · affects up to 10.0.1.2 · reported by PatchstackMedium 5.4
- Sep 4, 2024The PixelYourSite – Your smart PIXEL (TAG) & API Manager and the PixelYourSite PRO plugins for WordPress are vulnerable to Sensitive Information Exposure in allCVE-2024-7870 · affects up to 9.7.1 · reported by WordfenceMedium 6.5
- Jul 21, 2024PixelYourSite – Your smart PIXEL (TAG) Manager: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-37447 · affects up to 9.6.1.1 · reported by PatchstackMedium 5.9
- Jun 9, 2023PixelYourSite: Stored Cross-Site ScriptingCVE-2023-2584 · affects up to 9.3.6 · reported by WordfenceMedium 4.4
- Mar 13, 2023PixelYourSite PixelYourSite – Your smart PIXEL: Cross-Site Request Forgery (CSRF)CVE-2023-22700 · affects up to 9.3.0 · reported by PatchstackMedium 4.3
- May 14, 2018PixelYourSite plugin prior to version 5.3.0 for: Cross-site scriptingCVE-2018-0578 · fixed in 5.3.0 · reported by vultures@jpcert.or.jpMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.