WordPress plugin · pagelayer
Is Page Builder safe?
Safe on 2.2.2 or newer.
The current version, 2.2.2, is past every affected range on record (25 of 25 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 25
- High or critical
- 0
- Exploited
- none
- Current version
- 2.2.2
- Last updated
- Sep 24, 2026
- Active installs
- 400,000+
Every recorded flaw
- Jun 13, 2026Page Builder: Pagelayer – Drag and Drop website builder: Stored Cross-Site ScriptingCVE-2026-3297 · affects up to 2.0.9 · reported by WordfenceMedium 6.4
- Jun 13, 2026Page Builder: Pagelayer – Drag and Drop website builder: Incorrect AuthorizationCVE-2026-2470 · affects up to 2.0.9 · reported by WordfenceMedium 4.3
- Apr 8, 2026Page Builder: Pagelayer: Stored Cross-Site ScriptingCVE-2026-2509 · affects up to 2.0.8 · reported by WordfenceMedium 6.4
- Apr 8, 2026PageLayer: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2026-39469 · affects up to 2.0.8 · reported by PatchstackMedium 4.3
- Mar 28, 2026Page Builder: Pagelayer – Drag and Drop website builder: Improper Neutralization of CRLF Sequences ('CRLF Injection')CVE-2026-2442 · affects up to 2.0.7 · reported by WordfenceMedium 5.3
- Nov 12, 2025Page Builder: Pagelayer – Drag and Drop website builder: Insecure Direct Object ReferenceCVE-2025-12366 · affects up to 2.0.5 · reported by WordfenceMedium 4.3
- May 24, 2025Page Builder: Pagelayer – Drag and Drop website builder: Reflected Cross-Site ScriptingCVE-2025-4223 · affects up to 2.0.0 · reported by WordfenceMedium 4.7
- May 23, 2025Page Builder: Pagelayer – Drag and Drop website builder: Stored Cross-Site ScriptingCVE-2024-13427 · affects up to 2.0.0 · fixed in 1.9.9 · reported by WordfenceMedium 6.4
- May 15, 2025Page Builder: Pagelayer: Does not sanitise and escape some of its settingsCVE-2024-8618 · fixed in 1.9.0 · reported by WPScanMedium 4.8
- May 15, 2025Page Builder: Pagelayer: Does not sanitise and escape some of its settingsCVE-2024-8426 · fixed in 1.8.8 · reported by WPScanMedium 4.8
- Mar 13, 2025Page Builder: Pagelayer – Drag and Drop website builder: Unauthorized post publicationCVE-2025-2104 · affects up to 1.9.8 · reported by WordfenceMedium 4.3
- Mar 12, 2025Page Builder: Pagelayer – Drag and Drop website builder: Information ExposureCVE-2024-13430 · affects up to 1.9.8 · reported by WordfenceMedium 4.3
- Mar 10, 2025Page Builder: Pagelayer – Drag and Drop website builder: Cross-Site Request ForgeryCVE-2025-1926 · affects up to 1.9.8 · reported by WordfenceMedium 4.3
- Jan 24, 2025PageLayer: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-24573 · affects up to 1.9.4 · reported by PatchstackMedium 6.5
- Dec 9, 2024PageLayer: Missing AuthorizationCVE-2023-49196 · affects up to 1.7.7 · reported by PatchstackMedium 4.3
- Sep 17, 2024PageLayer: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-43972 · affects up to 1.8.7 · reported by PatchstackMedium 5.9
- Jun 9, 2024PageLayer: Missing AuthorizationCVE-2024-30465 · affects up to 1.8.1 · reported by PatchstackMedium 6.5
- Apr 9, 2024Page Builder: Pagelayer – Drag and Drop website builder: Stored Cross-Site ScriptingCVE-2024-2504 · affects up to 1.8.4 · reported by WordfenceMedium 6.4
- Mar 7, 2024Page Builder: Pagelayer – Drag and Drop website builder: Stored Cross-Site ScriptingCVE-2024-2127 · affects up to 1.8.3 · reported by WordfenceMedium 6.4
- Feb 27, 2024Page Builder: Pagelayer: Does not sanitise and escape some of its settingsCVE-2023-7115 · fixed in 1.8.1 · reported by WPScanMedium 4.8
- Feb 23, 2024Page Builder: Pagelayer – Drag and Drop website builder: Stored Cross-Site ScriptingCVE-2024-1590 · affects up to 1.8.2 · reported by WordfenceMedium 4.6
- Jan 29, 2024Page Builder: Pagelayer: Doesn't prevent attackers with administrator privileges from inserting malicious JavaScript inside a post's header or footer codeCVE-2023-5124 · fixed in 1.8.0 · reported by WPScanMedium 4.8
- Jan 3, 2024Page Builder: Pagelayer – Drag and Drop website builder: Stored Cross-Site ScriptingCVE-2023-6738 · affects up to 1.7.8 · reported by WordfenceMedium 5.4
- Oct 16, 2023Page Builder: Pagelayer: Doesn't prevent attackers with author privileges and higher from inserting malicious JavaScript inside a post's header or footer codeCVE-2023-5087 · fixed in 1.7.8 · reported by WPScanMedium 5.4
- Oct 16, 2023Page Builder: Pagelayer: Doesn't prevent unauthenticated attackers from updating a post's header or footer code on scheduled postsCVE-2023-4687 · fixed in 1.7.7 · reported by WPScanMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.