WordPress plugin · newsletters-lite
Is Newsletters safe?
A flaw affects the current version.
The newest release on wordpress.org, 4.18.2, is inside the affected range of CVE-2026-116863, so there may be no fix yet. Check the changelog; if it doesn’t mention the fix, deactivate it until it does.
- Flaws on record
- 42
- High or critical
- 26
- Exploited
- none
- Current version
- 4.18.2
- Last updated
- Oct 20, 2026
- Active installs
- 2,000+
Every recorded flaw
- Oct 27, 2026Newsletters: Cross-Site Request Forgery (CSRF)CVE-2026-116863 · affects up to 4.18.2 · reported by PatchstackCritical 9.6
- Oct 24, 2026Newsletters: Deserialization of Untrusted DataCVE-2026-94075 · affects up to 4.18.1 · reported by PatchstackCritical 9.8
- Oct 24, 2026Newsletters: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-111402 · affects up to 4.18.1 · reported by PatchstackCritical 9.3
- Sep 23, 2026Newsletters: Does not perform an ownership check on some of its subscriber management actionsCVE-2026-16264 · fixed in 4.18.1 · reported by WPScanMedium 6.5
- Sep 17, 2026Administrator SQL Injection in Newsletters <= 4.18 versions.CVE-2026-66619 · affects up to 4.18 · reported by PatchstackHigh 7.6
- Aug 29, 2026Newsletters: Does not perform any nonce or capability checkCVE-2026-17522 · fixed in 4.17 · reported by WPScanMedium 5.4
- Aug 29, 2026Newsletters: Does not generate its API key using a sufficiently random sourceCVE-2026-17520 · fixed in 4.17 · reported by WPScanMedium 4.8
- Aug 25, 2026Newsletters: Authorization bypassCVE-2026-75908 · affects up to 4.17 · reported by WordfenceMedium 4.3
- Aug 8, 2026Newsletters: Does not strictly compare its API authentication keyCVE-2026-16269 · fixed in 4.16 · reported by WPScanMedium 4.8
- Aug 8, 2026Newsletters: Does not restrict the classes allowedCVE-2026-16267 · fixed in 4.16 · reported by WPScanHigh 8.1
- Aug 6, 2026Newsletters: Does not authenticate or validate a bounce-processing request before fetching a user-supplied URL on the server sideCVE-2026-16268 · fixed in 4.16 · reported by WPScanHigh 8.2
- Jul 28, 2026Newsletters Lite: Stored Cross-Site ScriptingCVE-2026-12939 · affects up to 4.15 · reported by WordfenceMedium 6.4
- Jul 28, 2026Newsletters Lite: Stored Cross-Site ScriptingCVE-2026-12938 · affects up to 4.15 · reported by WordfenceMedium 6.4
- Jul 14, 2026Newsletters: Does not prevent deserialization of untrusted input that is stored through a public formCVE-2026-12583 · fixed in 4.15 · reported by WPScanHigh 8.1
- Jul 13, 2026Newsletters: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2026-57394 · affects up to 4.14 · reported by PatchstackHigh 7.1
- Jun 26, 2026newsletters_subscribers Broken Access Control in Newsletters <= 4.13 versions.CVE-2026-57645 · reported by PatchstackHigh 8.1
- Jun 26, 2026Unauthenticated Broken Access Control in Newsletters <= 4.13 versions.CVE-2026-54840 · reported by PatchstackHigh 7.3
- Jun 10, 2026Newsletters: Time-based SQL InjectionCVE-2026-3018 · affects up to 4.13 · reported by Wordfence1.4% oddsHigh 7.5
- Jan 8, 2026Newsletters: Deserialization of Untrusted DataCVE-2025-67911 · affects up to 4.11 · reported by PatchstackCritical 9.8
- Dec 30, 2025Newsletters: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-69020 · affects up to 4.12 · reported by PatchstackMedium 6.5
- Aug 20, 2025Newsletters: Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')CVE-2025-54034 · affects up to 4.10 · reported by PatchstackHigh 7.5
- Jul 16, 2025Newsletters: Cross-Site Request Forgery (CSRF)CVE-2025-54035 · affects up to 4.10 · reported by PatchstackMedium 4.3
- May 31, 2025Newsletters: Local File InclusionCVE-2025-4857 · affects up to 4.9.9.9 · reported by WordfenceHigh 7.2
- May 13, 2025Newsletters: Time-based SQL InjectionCVE-2025-3107 · affects up to 4.9.9.8 · reported by WordfenceMedium 6.5
- Mar 27, 2025Newsletters: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-30921 · affects up to 4.9.9.7 · reported by PatchstackHigh 7.6
- Mar 26, 2025Newsletters: Stored Cross-Site ScriptingCVE-2025-2009 · affects up to 4.9.9.7 · reported by WordfenceHigh 7.2
- Mar 22, 2025Newsletters: Reflected Cross-Site ScriptingCVE-2024-13739 · affects up to 4.9.9.7 · reported by WordfenceMedium 6.1
- Feb 4, 2025Newsletters: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-24599 · affects up to 4.9.9.6 · reported by PatchstackHigh 7.1
- Oct 29, 2024Newsletters: Stored Cross-Site ScriptingCVE-2024-10181 · affects up to 4.9.9.4 · reported by WordfenceMedium 6.4
- Oct 6, 2024Newsletters: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-47346 · affects up to 4.9.9.1 · reported by PatchstackHigh 7.1
- Sep 6, 2024Newsletters: Privilege escalationCVE-2024-8247 · affects up to 4.9.9.2 · reported by WordfenceHigh 8.8
- Aug 18, 2024Newsletters: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-43279 · affects up to 4.9.8 · reported by PatchstackHigh 7.1
- Aug 15, 2024Newsletters: Full Path DisclosureCVE-2024-7411 · affects up to 4.9.9 · reported by WordfenceMedium 5.3
- Jun 21, 2024Newsletters: Cross Site Request Forgery (CSRF)CVE-2024-37227 · affects up to 4.9.7 · reported by PatchstackMedium 4.3
- Jun 8, 2024Newsletters: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-35718 · affects up to 4.9.5 · reported by PatchstackHigh 7.1
- Apr 24, 2024Newsletters: Unrestricted Upload of File with Dangerous TypeCVE-2024-32954 · affects up to 4.9.5 · reported by PatchstackCritical 9.1
- Apr 24, 2024Newsletters: Insertion of Sensitive Information into Log FileCVE-2024-32953 · affects up to 4.9.5 · reported by PatchstackHigh 7.5
- Jan 16, 2024Newsletters: Does not properly escape user-controlled parametersCVE-2023-4797 · fixed in 4.9.3 · reported by WPScanHigh 7.2
- Nov 10, 2023Cross-Site Request Forgery (CSRF) vulnerability in Tribulant Newsletters plugin <= 4.8.8 versions.CVE-2023-30478 · affects up to 4.8.8 · reported by PatchstackMedium 5.4
- Aug 22, 2019The newsletters-lite plugin before 4.6.8.6 for WordPress has PHP object injection.CVE-2018-20987 · fixed in 4.6.8.6 · reported by MITRE2.1% oddsCritical 9.8
- Aug 15, 2019wp-admin/admin-ajax.php?action=newsletters_exportmultiple in the Tribulant Newsletters plugin before 4.6.19 for WordPress allows directory traversal with resultCVE-2019-14788 · fixed in 4.6.19 · reported by MITRE3.7% oddsHigh 8.8
- Aug 9, 2019The Tribulant Newsletters plugin before 4.6.19 for WordPress allows XSS via the wp-admin/admin-ajax.php?action=newsletters_load_new_editor contentarea parameterCVE-2019-14787 · fixed in 4.6.19 · reported by MITRE1.0% oddsMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.