WordPress plugin · ml-slider
Is Slider, Gallery, and Carousel by MetaSlider safe?
Safe on 3.114.0 or newer.
The current version, 3.114.0, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 3
- Exploited
- none
- Current version
- 3.114.0
- Last updated
- Oct 27, 2026
- Active installs
- 500,000+
Every recorded flaw
- Aug 6, 2026Slider, Gallery, and Carousel by MetaSlider – Image Slider, Video Slider: Stored Cross-Site ScriptingCVE-2026-18400 · affects up to 3.111.0 · reported by WordfenceMedium 6.4
- Jun 15, 2026Editor Remote Code Execution (RCE) in Responsive Slider by MetaSlider <= 3.106.0 versions.CVE-2026-39465 · affects up to 3.106.0 · reported by PatchstackCritical 9.1
- Apr 21, 2026Responsive Slider by MetaSlider: Deserialization of Untrusted DataCVE-2026-39467 · affects up to 3.106.0 · reported by PatchstackHigh 7.2
- Jun 14, 2025Slider, Gallery, and Carousel by MetaSlider: Stored Cross-Site ScriptingCVE-2025-5337 · affects up to 3.98.0 · reported by WordfenceMedium 6.4
- Mar 24, 2025Slider, Gallery, and Carousel by MetaSlider: Does not sanitise and escape some of its settingsCVE-2025-1203 · fixed in 3.95.0 · reported by WPScanLow 3.5
- Mar 24, 2025Slider, Gallery, and Carousel by MetaSlider: Does not sanitise and escape some of its settingsCVE-2025-1062 · fixed in 3.95.0 · reported by WPScanLow 3.5
- Feb 22, 2025Responsive Slider by MetaSlider: Deserialization of Untrusted DataCVE-2025-26763 · affects up to 3.94.0 · reported by PatchstackCritical 9.8
- Jan 27, 2025Responsive Slider by MetaSlider: Cross-Site Request Forgery (CSRF)CVE-2025-24533 · affects up to 3.92.0 · reported by PatchstackMedium 5.4
- Apr 11, 2024Slider, Gallery, and Carousel by MetaSlider – Responsive WordPress Slideshows: Stored Cross-Site ScriptingCVE-2024-3285 · affects up to 3.70.0 · reported by WordfenceMedium 6.4
- Oct 10, 2022Slider, Gallery, and Carousel by MetaSlider: Does not sanitise and escape some of its Gallery Image parametersCVE-2022-2823 · fixed in 3.27.9 · reported by WPScanMedium 4.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.